Bug 446794 - LOST WRITES TO NFS FILES OPENED WITH O_SYNC
LOST WRITES TO NFS FILES OPENED WITH O_SYNC
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Peter Staubach
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 23:13 EDT by wengang wang
Modified: 2008-06-17 15:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.9-57
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 15:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch (589 bytes, patch)
2008-05-15 23:13 EDT, wengang wang
no flags Details | Diff

  None (edit)
Description wengang wang 2008-05-15 23:13:29 EDT
a file under NFS mount point is opened O_SYNC option.
the NFS partition on server is nearly full.
although some writes returns successfully, the file content is not the expected.

I thinks it because there is miss of syncing the write operation in nfs/file.c
which is corrected in later rhel release.

attached the patch.
Comment 1 wengang wang 2008-05-15 23:13:29 EDT
Created attachment 305605 [details]
the patch
Comment 2 Peter Staubach 2008-06-17 15:12:07 EDT
Would you describe what the expected contents of the file
would be, if they weren't what was expected, please?

The suggest patch has been part of RHEL-4 since 2.6.9-57, so
any kernel newer than that should have that support.  Would
you try your situation on a newer kernel and then if there is
still a problem, then reopen this bugzilla, please?

Note You need to log in before you can comment on or make changes to this bug.