Bug 4468 - x server crashes due to font path problem
x server crashes due to font path problem
Product: Red Hat Raw Hide
Classification: Retired
Component: Xconfigurator (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
Depends On:
  Show dependency treegraph
Reported: 1999-08-10 22:15 EDT by prabirm
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-23 21:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description prabirm 1999-08-10 22:15:09 EDT
The XConfigurator configures the font path entries in the
file "/etc/X11/XF86Config" as

   FontPath   "unix/:-1"

because of this the x-server always crashes and you can
never start X11 using "startx" or directly after boot up.

I changed the parameters to the followings:

#   FontPath   "unix/:-1"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath    "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"

And "xdm" or "kdm" is working perfectly now.

BTW, the rawhide release date is "4th August, 1999"
I have a ViewSonic P655 with ATI Rage Pro II video card

Comment 1 Bill Nottingham 1999-08-11 10:04:59 EDT
Did you actually have the font server running?
Comment 2 Cristian Gafton 1999-08-23 21:09:59 EDT
Probably the font server was not running, because it works for me.

Note You need to log in before you can comment on or make changes to this bug.