Bug 446802 - segfault if syslog message is longer than 80 characters
segfault if syslog message is longer than 80 characters
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: piranha (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
: Patch
: 476810 (view as bug list)
Depends On:
Blocks: 454626
  Show dependency treegraph
 
Reported: 2008-05-16 02:47 EDT by Andrew Ryan
Modified: 2010-10-22 21:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:54:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from email thread (438 bytes, patch)
2008-05-16 02:47 EDT, David Robinson
no flags Details | Diff
corefile (68.66 KB, application/x-bzip)
2008-07-03 12:51 EDT, Vince Worthington
no flags Details

  None (edit)
Description David Robinson 2008-05-16 02:47:17 EDT
Description of problem:
nanny segfaults if it tries to log messages (syslog) that are longer than 80
characters.

Version-Release number of selected component (if applicable):
piranha-0.8.4-7.el5

How reproducible:
Not sure.

Steps to Reproduce:
1. Not sure.
  
Actual results:
Pulse fails to start since all started nanny processes die right after startup:
Mar 28 15:06:28 hzmlldbb01 pulse[20661]: STARTING PULSE AS MASTER
Mar 28 15:06:38 hzmlldbb01 pulse[20661]: partner dead: activating lvs
Mar 28 15:06:38 hzmlldbb01 lvs[20682]: starting virtual service
micromoney-comfort.de-https active: 443
Mar 28 15:06:38 hzmlldbb01 lvs[20682]: create_monitor for
micromoney-comfort.de-https/hzmlweb01 running as pid 20696
Mar 28 15:06:38 hzmlldbb01 kernel: nanny[20696]: segfault at 0000000000000001
rip 0000003b98c76150 rsp 00007fff331c7528 error 4
Mar 28 15:06:38 hzmlldbb01 kernel: nanny[20697]: segfault at 0000000000000001
rip 0000003b98c76150 rsp 00007fff4de9c208 error 4

Expected results:
No segmentation fault. pulse and nanny start successfully.

Additional info:
The problem was returned on the linux-cluster mailing list. Patch is attached.

http://www.redhat.com/archives/linux-cluster/2007-November/msg00153.html
Comment 1 David Robinson 2008-05-16 02:47:17 EDT
Created attachment 305642 [details]
patch from email thread
Comment 6 Vince Worthington 2008-07-03 12:51:29 EDT
Created attachment 310940 [details]
corefile
Comment 8 Marek Grac 2008-07-09 09:22:16 EDT
Patch applied, vsnprintf was not used in any other source file.
Comment 11 errata-xmlrpc 2009-01-20 15:54:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0095.html
Comment 13 Marek Grac 2009-02-10 11:31:01 EST
*** Bug 476810 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.