Bug 446803 - Synaptics middle button emulation does not work
Synaptics middle button emulation does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 03:38 EDT by Frank A Ekern
Modified: 2008-08-28 11:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-28 11:01:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.20 KB, text/plain)
2008-05-16 03:38 EDT, Frank A Ekern
no flags Details

  None (edit)
Description Frank A Ekern 2008-05-16 03:38:42 EDT
Description of problem:
In Fedora 9 the middle button emulation (i.e. pressing left and right buttons
simultaneously) does not work with synaptics.
I have disabled the Touchpad and is only using the "pointing stick" (i.e
"GuestMouse"). As a test I enabled the Touchpad, and the middle button emulated
worked correctly with the two mousebuttons located next to the touch pad, but it
still did not work for the mouse buttons used for the pointing stick.
The middle button emulation has worked correctly in Fedora 7 and Fedora 8 on the
same hardware.

Hardware platform:
Dell Latitude D830

Version-Release number of selected component (if applicable):
synaptics-0.14.6-7.fc9.i386

How reproducible:
Always. 

Steps to Reproduce:
1. Use hardware with a touchpad/pointing stick combination with separate
mousebuttons for both point
2. Enable GuestMouse, set TouchpadOff to 1
3. Set EmulateMidButtonTime to a reasonable value (75)
4. Try pressing both mouse buttons simultaneously 
  
Actual results:
No middle button emulation

Expected results:
Middle button should be emulated

Additional info:
Output of 'synclient -l':
Parameter settings:
    LeftEdge             = 120
    RightEdge            = 830
    TopEdge              = 120
    BottomEdge           = 650
    FingerLow            = 53
    FingerHigh           = 58
    MaxTapTime           = 0
    MaxTapMove           = 110
    MaxDoubleTapTime     = 180
    SingleTapTimeout     = 180
    ClickTime            = 100
    FastTaps             = 0
    EmulateMidButtonTime = 75
    VertScrollDelta      = 0
    HorizScrollDelta     = 0
    VertEdgeScroll       = 1
    HorizEdgeScroll      = 1
    VertTwoFingerScroll  = 0
    HorizTwoFingerScroll = 0
    MinSpeed             = 0.3
    MaxSpeed             = 0.75
    AccelFactor          = 0.0015
    EdgeMotionMinZ       = 30
    EdgeMotionMaxZ       = 160
    EdgeMotionMinSpeed   = 1
    EdgeMotionMaxSpeed   = 400
    EdgeMotionUseAlways  = 0
    UpDownScrolling      = 1
    LeftRightScrolling   = 1
    UpDownRepeat         = 1
    LeftRightRepeat      = 1
    ScrollButtonRepeat   = 100
    TouchpadOff          = 1
    GuestMouseOff        = 0
    LockedDrags          = 0
    RTCornerButton       = 0
    RBCornerButton       = 0
    LTCornerButton       = 0
    LBCornerButton       = 0
    TapButton1           = 0
    TapButton2           = 0
    TapButton3           = 0
    CircularScrolling    = 0
    CircScrollDelta      = 0.01
    CircScrollTrigger    = 0
    CircularPad          = 0
    PalmDetect           = 1
    PalmMinWidth         = 10
    PalmMinZ             = 200
    CoastingSpeed        = 0
    PressureMotionMinZ   = 30
    PressureMotionMaxZ   = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
Comment 1 Frank A Ekern 2008-05-16 03:38:42 EDT
Created attachment 305648 [details]
xorg.conf
Comment 2 Peter Hutterer 2008-07-17 20:53:45 EDT
Could be http://bugs.freedesktop.org/show_bug.cgi?id=15956
These dell stick/touchpad devices are a bit screwed.
Can you provide a log file please?

Also, please start xev and click into the window multiple times with each
button, then attach the output of xev as well.
Comment 3 Frank A Ekern 2008-08-07 03:41:29 EDT
This problem has solved itself and the middle button emulation is now working correctly, probably due to an package update (I do not know which package or when the problem was fixed).
Comment 4 Matěj Cepl 2008-08-28 11:01:00 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.