Bug 446812 - oobase report component broken
oobase report component broken
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 05:00 EDT by A. Folger
Modified: 2008-05-30 08:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 08:01:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 87709 None None None Never

  None (edit)
Description A. Folger 2008-05-16 05:00:22 EDT
Description of problem:
Since upgrading from Fedora 8 to 9, and thus from OOo 2.3 to 2.4, my old reports
fail, reporting that it cannot execute the query because it contains '' (I
assume the empty string), even though the queries are doing just fine.

In addition, newly generated reports (using the report generator wizard) are
static, even though I explicitly try to create dynamic reports (that is the
default, anyway)

This means that in OOo 2.4, the report generator is of much reduced usefulness.

In the short term, I would appreciate the ability to force yum to downgrade to
Fedora 9 compatible OOo 2.3 packages. However, this bug should preferably be
fixed asap.

Version-Release number of selected component (if applicable):
F9, OOo 2.4

How reproducible:
Every time

Steps to Reproduce:
1. Open OOo database file
2. Either use reports created under OOo 2.3, or try creating a new report
3. see how old reports don't work, while new ones are static (change query after
report creation and see how the report remains the same)
  
Actual results:
Working, dynamic reports

Expected results:
Neither

Additional info:
Comment 1 Caolan McNamara 2008-05-16 05:09:55 EDT
Can you attach a sample .odb that works in 2.3 and fails in 2.4, and the exact
string of the error.
Comment 2 A. Folger 2008-05-16 06:00:09 EDT
I just downloaded OOo 2.3 from Fedora 8 updates and, since hunspell changed,
simply added --nodeps to the rpm command. I am not sure what that means for my
spell checking abilities until I update again, but I tested the report generator
and it works.

Interestingly enough, the report I created with v2.4 remains a static report.
However, I just recreated that report under 2.3, and it works 100%.
Comment 3 Caolan McNamara 2008-05-30 08:01:31 EDT
Known as http://www.openoffice.org/issues/show_bug.cgi?id=87709
2.4.1 is due in about a week. There will be a 2.4.1 update for F-9 at that stage.

Note You need to log in before you can comment on or make changes to this bug.