Bug 446813 - Assertion failures, occasional termination; regression from Fedora 8
Assertion failures, occasional termination; regression from Fedora 8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 05:12 EDT by Tim Waugh
Modified: 2008-07-02 02:34 EDT (History)
0 users

See Also:
Fixed In Version: 2.16.3-7.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 02:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-05-16 05:12:24 EDT
Description of problem:
This small program:

==>
#!/usr/bin/python
import gtk.gdk
gtk.gdk.threads_init()
a = gtk.FileChooserButton ('title')
<==

often gives assertion failures, and occasionally terminates abnormally.

The assertion failure output looks like this:

==>
test.py:4: Warning: IA__g_object_new_valist: object class `GThemedIcon' has no
property named `names'
  a = gtk.FileChooserButton ('title')

(test.py:8759): GLib-GIO-CRITICAL **: g_themed_icon_constructed: assertion
`themed->names != NULL && themed->names[0] != NULL' failed
<==

or sometimes like this:

==>
./test.py:4: Warning: IA__g_object_new_valist: object class `GThemedIcon' has no
property named `names'
  a = gtk.FileChooserButton ('title')

(test.py:8935): GLib-GIO-CRITICAL **: g_themed_icon_constructed: assertion
`themed->names != NULL && themed->names[0] != NULL' failed

(test.py:8935): GLib-GIO-CRITICAL **: g_themed_icon_constructed: assertion
`themed->names != NULL && themed->names[0] != NULL' failed

(test.py:8935): GLib-CRITICAL **: g_strv_length: assertion `str_array != NULL'
failed
<==

while the abort output looks like this:

==>

GLib-GObject-ERROR **: g_type_plugin_*() invalidly modified type `GThemedIcon'
aborting...
<==

This test case was distilled from system-config-printer, and this bug has the
effect of occasionally causing that program to occasionally abort.

Version-Release number of selected component (if applicable):
glib2-2.16.3-5.fc9.x86_64

How reproducible:
About 40% of the time.

Steps to Reproduce:
1. ./test.py
  
Actual results:
Assertions, errors, mayhem.

Expected results:
No output, normal exit.

Additional info:
Works fine in Fedora 8.
Comment 1 Fedora Update System 2008-06-16 23:31:22 EDT
glib2-2.16.3-6.fc9 has been submitted as an update for Fedora 9
Comment 2 Fedora Update System 2008-06-17 23:14:56 EDT
glib2-2.16.3-7.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glib2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5422
Comment 3 Tim Waugh 2008-06-19 04:14:43 EDT
Fix verified.  Thanks!
Comment 4 Fedora Update System 2008-07-02 02:34:08 EDT
glib2-2.16.3-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.