Bug 446818 - Mousewheel cannot be disabled
Mousewheel cannot be disabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
http://bugs.freedesktop.org/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 05:56 EDT by Jan Kratochvil
Modified: 2008-07-15 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 22:16:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (1.24 KB, text/plain)
2008-05-16 05:56 EDT, Jan Kratochvil
no flags Details
/var/log/Xorg.0.log (77.71 KB, text/plain)
2008-05-16 17:11 EDT, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2008-05-16 05:56:03 EDT
Description of problem:
On F8 I had on my USB mouse the mousewheel disabled.  After upgrading to F9 the
configuration change started to be ignored.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mouse-1.3.0-2.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install attached `/etc/X11/xorg.conf'.
   Therefore: Option "ZAxisMapping" "0 0"
2. Start X by gdm.
3. Scroll by mousewheel.

Actual results:
It scrolls the window (such as gnome-terminal or xterm or firefox).

Expected results:
The mousewheel scrolling is ignored.

Additional info:
Bus 001 Device 004: ID 046d:c040 Logitech, Inc. Corded Tilt-Wheel Mouse
(They no longer sell a three-button mice without a mousewheel!)
Comment 1 Jan Kratochvil 2008-05-16 05:56:03 EDT
Created attachment 305668 [details]
/etc/X11/xorg.conf
Comment 2 Matěj Cepl 2008-05-16 16:01:32 EDT
Can I get /var/log/Xorg.*.log attached as well, please? Díky za bug.
Comment 3 Jan Kratochvil 2008-05-16 17:11:22 EDT
Created attachment 305755 [details]
/var/log/Xorg.0.log
Comment 4 Matěj Cepl 2008-05-16 18:56:30 EDT
Assigning to developer, but just a question -- why do you have synaptics section
at all? This is normal mouse, right? Not touchpad?
Comment 5 Jan Kratochvil 2008-05-17 02:42:16 EDT
It is a normal USB mouse:
  http://www.logitech.com/repository/437/jpg/3221.1.0.jpg
And it is on a T60 notebook which has also a touchpoint and a touchpad.
All three input devices work (for moving and clicking).

While the Synaptics section was there IMO by default I would need it anyway as I
have there the option:
  Option "TouchpadOff" "2"
to disable its tapping (but I no longer care as I no longer use the touchpad).
Comment 6 Peter Hutterer 2008-07-15 22:16:32 EDT
You're seeing a conflict between hotplugged input devices and the actual devices.
After the configured devices are created, all devices found by HAL are added.
These are added with the evdev driver, but without the mouse wheel option you
specified.

Furthermore, evdev grabs the device file, so any device added through hotplug
won't feed into /dev/input/mice (i.e. all mice).

There are two solutions to this:
- add "Option "AutoAddDevices" "off" to your ServerLayout. This deactivates
input device hotplugging and the mouse will use the options specified in the config.
- make evdev capable of ZAxisMapping options. I filed the bug for a
feature-request upstream. [1]

For now, the first option is better. 
Closing as NOTABUG, since it was caused by a configuration problem.

[1] http://bugs.freedesktop.org/show_bug.cgi?id=16726

Note You need to log in before you can comment on or make changes to this bug.