Bug 446820 - yakuake missing kdebase in dependency
yakuake missing kdebase in dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yakuake (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 06:06 EDT by Jan Tluka
Modified: 2008-05-21 06:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.8.1-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 06:55:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Tluka 2008-05-16 06:06:52 EDT
Description of problem:
I installed yakuake via yum. Launched yakuake and this failed with 'could not
find drkonqi executable' error.

--------
INSTALL:

[root@machine ~]# yum install yakuake
Repository livna is listed more than once in the configuration
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package yakuake.x86_64 0:2.8.1-3.fc8 set to be updated
--> Processing Dependency: libkdesu.so.4()(64bit) for package: yakuake
--> Processing Dependency: libkdefx.so.4()(64bit) for package: yakuake
--> Processing Dependency: libkdecore.so.4()(64bit) for package: yakuake
--> Processing Dependency: libDCOP.so.4()(64bit) for package: yakuake
--> Processing Dependency: libkio.so.4()(64bit) for package: yakuake
--> Processing Dependency: libkdeui.so.4()(64bit) for package: yakuake
--> Processing Dependency: libqt-mt.so.3()(64bit) for package: yakuake
--> Processing Dependency: libkwalletclient.so.1()(64bit) for package: yakuake
--> Running transaction check
---> Package kdelibs.x86_64 6:3.5.9-5.fc8 set to be updated
--> Processing Dependency: libkdnssd for package: kdelibs
--> Processing Dependency: libmcop.so.1()(64bit) for package: kdelibs
--> Processing Dependency: arts >= 8:1.5.9 for package: kdelibs
--> Processing Dependency: kde-settings >= 3.5 for package: kdelibs
--> Processing Dependency: libartsflow_idl.so.1()(64bit) for package: kdelibs
--> Processing Dependency: libqtmcop.so.1()(64bit) for package: kdelibs
--> Processing Dependency: libkmedia2_idl.so.1()(64bit) for package: kdelibs
--> Processing Dependency: libartsflow.so.1()(64bit) for package: kdelibs
--> Processing Dependency: libsoundserver_idl.so.1()(64bit) for package: kdelibs
---> Package qt.x86_64 1:3.3.8b-2.fc8 set to be updated
--> Running transaction check
---> Package kde-settings.noarch 0:3.5-38.fc8 set to be updated
---> Package kdnssd-avahi.x86_64 0:0.1.3-0.2.20060713svn.fc8 set to be updated
--> Processing Dependency: libavahi-qt3.so.1()(64bit) for package: kdnssd-avahi
---> Package arts.x86_64 8:1.5.9-1.fc8 set to be updated
--> Running transaction check
---> Package avahi-qt3.x86_64 0:0.6.21-8.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 yakuake                 x86_64     2.8.1-3.fc8      updates           195 k
Installing for dependencies:
 arts                    x86_64     8:1.5.9-1.fc8    updates           1.2 M
 avahi-qt3               x86_64     0.6.21-8.fc8     updates            19 k
 kde-settings            noarch     3.5-38.fc8       updates            16 k
 kdelibs                 x86_64     6:3.5.9-5.fc8    updates            17 M
 kdnssd-avahi            x86_64     0.1.3-0.2.20060713svn.fc8  base            
  45 k
 qt                      x86_64     1:3.3.8b-2.fc8   updates           3.6 M

Transaction Summary
=============================================================================
Install      7 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 22 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): qt-3.3.8b-2.fc8.x8 100% |=========================| 3.6 MB    00:05     
(2/7): arts-1.5.9-1.fc8.x 100% |=========================| 1.2 MB    00:01     
(4/7): kde-settings-3.5-3 100% |=========================|  16 kB    00:00     
(5/7): yakuake-2.8.1-3.fc 100% |=========================| 195 kB    00:00     
(6/7): kdelibs-3.5.9-5.fc 100% |=========================|  17 MB    00:25     
(7/7): avahi-qt3-0.6.21-8 100% |=========================|  19 kB    00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: qt                           ######################### [1/7] 
  Installing: avahi-qt3                    ######################### [2/7] 
  Installing: arts                         ######################### [3/7] 
  Installing: kdnssd-avahi                 ######################### [4/7] 
  Installing: kdelibs                      ######################### [5/7] 
  Installing: yakuake                      ######################### [6/7] 
  Installing: kde-settings                 ######################### [7/7] 

Installed: yakuake.x86_64 0:2.8.1-3.fc8
Dependency Installed: arts.x86_64 8:1.5.9-1.fc8 avahi-qt3.x86_64 0:0.6.21-8.fc8
kde-settings.noarch 0:3.5-38.fc8 kdelibs.x86_64 6:3.5.9-5.fc8
kdnssd-avahi.x86_64 0:0.1.3-0.2.20060713svn.fc8 qt.x86_64 1:3.3.8b-2.fc8
Complete!

-------
LAUNCH: (as ordinary user)

[~] $ yakuake
kbuildsycoca running...
DCOP Cleaning up dead connections.
DCOP aborting (delayed) call from 'anonymous-13993' to 'yakuake'
KCrash: Application 'yakuake' crashing...
Could not find 'drkonqi' executable.
KCrash cannot reach kdeinit, launching directly.

-------

looked around on the internet for a solution and found one about kdebase:
INSTALL:

[root@machine ~]# yum install kdebase
Repository livna is listed more than once in the configuration
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package kdebase.x86_64 6:3.5.9-7.fc8 set to be updated
--> Processing Dependency: libkonq.so.4()(64bit) for package: kdebase
--> Processing Dependency: libkonqsidebarplugin.so.1()(64bit) for package: kdebase
--> Processing Dependency: libksgrd.so.1()(64bit) for package: kdebase
--> Processing Dependency: libkasbar.so.1()(64bit) for package: kdebase
--> Processing Dependency: libkateinterfaces.so.0()(64bit) for package: kdebase
--> Processing Dependency: libkhotkeys_shared.so.1()(64bit) for package: kdebase
--> Processing Dependency: libksplashthemes.so.0()(64bit) for package: kdebase
--> Processing Dependency: libkdecorations.so.1()(64bit) for package: kdebase
--> Processing Dependency: libtaskmanager.so.1()(64bit) for package: kdebase
--> Processing Dependency: libtaskbar.so.1()(64bit) for package: kdebase
--> Processing Dependency: kde-settings-kdm for package: kdebase
--> Processing Dependency: libkickermain.so.1()(64bit) for package: kdebase
--> Processing Dependency: kdebase-libs = 6:3.5.9-7.fc8 for package: kdebase
--> Processing Dependency: xorg-x11-apps for package: kdebase
--> Processing Dependency: libkfontinst.so.0()(64bit) for package: kdebase
--> Running transaction check
---> Package kdebase-libs.x86_64 6:3.5.9-7.fc8 set to be updated
---> Package kde-settings-kdm.noarch 0:3.5-38.fc8 set to be updated
--> Processing Dependency: xorg-x11-xdm for package: kde-settings-kdm
--> Processing Dependency: fedorainfinity-kdm-theme for package: kde-settings-kdm
---> Package xorg-x11-apps.x86_64 0:7.3-1.fc8 set to be updated
--> Running transaction check
---> Package fedorainfinity-kdm-theme.noarch 0:1.0.4-1.fc8 set to be updated
---> Package xorg-x11-xdm.x86_64 1:1.1.6-2.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing for dependencies:
 fedorainfinity-kdm-theme  noarch     1.0.4-1.fc8      updates           1.1 M
 kde-settings-kdm        noarch     3.5-38.fc8       updates            17 k
 kdebase                 x86_64     6:3.5.9-7.fc8    updates            28 M
 kdebase-libs            x86_64     6:3.5.9-7.fc8    updates           1.0 M
 xorg-x11-apps           x86_64     7.3-1.fc8        base              266 k
 xorg-x11-xdm            x86_64     1:1.1.6-2.fc8    base              140 k

Transaction Summary
=============================================================================
Install      6 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 30 M
Is this ok [y/N]: y
Downloading Packages:
(2/6): kdebase-libs-3.5.9 100% |=========================| 1.0 MB    00:02     
(3/6): kdebase-3.5.9-7.fc 100% |=========================|  28 MB    01:19     
(4/6): kde-settings-kdm-3 100% |=========================|  17 kB    00:00     
(6/6): fedorainfinity-kdm 100% |=========================| 1.1 MB    00:03     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: xorg-x11-xdm                 ######################### [1/6] 
  Installing: xorg-x11-apps                ######################### [2/6] 
  Installing: fedorainfinity-kdm-theme     ######################### [3/6] 
  Installing: kdebase                      ######################### [4/6] 
  Installing: kde-settings-kdm             ######################### [5/6] 
  Installing: kdebase-libs                 ######################### [6/6] 

Dependency Installed: fedorainfinity-kdm-theme.noarch 0:1.0.4-1.fc8
kde-settings-kdm.noarch 0:3.5-38.fc8 kdebase.x86_64 6:3.5.9-7.fc8
kdebase-libs.x86_64 6:3.5.9-7.fc8 xorg-x11-apps.x86_64 0:7.3-1.fc8
xorg-x11-xdm.x86_64 1:1.1.6-2.fc8
Complete!

[root@machine ~]# rpm -ql kdebase | grep drkonqi
/usr/bin/drkonqi


--------
LAUNCH2: (running again with success)

[~] $ yakuake
kbuildsycoca running...
Reusing existing ksycoca
DCOP Cleaning up dead connections.


Version-Release number of selected component (if applicable):

[root@machine ~]# yakuake --version
Qt: 3.3.8b
KDE: 3.5.9-5.fc8 Fedora
Yakuake: 2.8.1


How reproducible:
100% - install yakuake and run it, see steps.


Steps to Reproduce:
1. (root)# yum install yakuake
2. (user)# yakuake
3. (root)# yum install kdebase
4. (user)# yakuake
  

Actual results:
yakuake could not start!


Expected results:
yakuake starts
Comment 1 Nicoleau Fabien 2008-05-17 12:11:05 EDT
I tried on F9.
At first yum installed those dependencies :
kde-filesystem-4-14.fc9.noarch
kde-settings-4.0-22.fc9.1.noarch
6:kdelibs-common-4.0.3-7.fc9.i386
6:kdelibs-4.0.3-7.fc9.i386
yakuake-2.9.1-1.fc9.i386

Then I had those error at launch :
#
yakuake(3593)/kdecore (KConfigSkeleton)
KCoreConfigSkeleton::KCoreConfigSkeleton: Creating KCoreConfigSkeleton ( 0x9b55e58 )
#
yakuake(3593)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::readConfig:
KCoreConfigSkeleton::readConfig()
#
yakuake(3593)/kdecore (KLibLoader) findLibraryInternal: plugins should not have
a 'lib' prefix: "libkonsolepart.so"
#
yakuake(3593)/kdecore (KLibLoader) findLibraryInternal: plugins should not have
a 'lib' prefix: "libkonsolepart.so"
#
yakuake(3593)/kdecore (KLibLoader) kde4Factory: The library "" does not offer a
qt_plugin_instance function.
#
yakuake(3593)/kdecore (KLibLoader) kde3Factory: The library "" does not offer an
"init_libkonsolepart" function.
#
findServiceByDesktopPath: knotify4.desktop not found
#
yakuake(3593): Couldn't start knotify from knotify4.desktop:  "Could not find
service 'knotify4.desktop'."
#
 
#
yakuake(3593)/kdeui (KNotification) KNotification::slotReceivedIdError: Error
while contacting notify daemon "The name org.kde.knotify was not provided by any
.service files"
#
yakuake(3593)/kdeui (KNotification) KNotification::~KNotification: 0

Then I installed kdebase-runtime but had still a message error telling that
yakuake could'nt start because konsole was missing.

After installing "kdebase", everithing is OK
Comment 2 Fedora Update System 2008-05-17 12:23:18 EDT
yakuake-2.8.1-4.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-05-21 06:55:51 EDT
yakuake-2.8.1-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.