This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446829 - Powertop uses wrong units
Powertop uses wrong units
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 07:09 EDT by Jindrich Novy
Modified: 2013-07-02 19:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:08:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix to correct units. (560 bytes, patch)
2008-05-16 07:09 EDT, Jindrich Novy
no flags Details | Diff

  None (edit)
Description Jindrich Novy 2008-05-16 07:09:01 EDT
Description of problem:
The processor frequencies are displayed as "Mhz" and "Ghz" what is a typo, the
correct units are "MHz" and "GHz".
How reproducible:
always

Steps to Reproduce:
1. run powertop
2. look at CPU frequencies
3.
  
Actual results:
Mhz

Expected results:
MHz

Additional information:
Posting the bug here since upstream is dead (home page gives 404 and mailing
list subsciption doesn't work)
Comment 1 Jindrich Novy 2008-05-16 07:09:01 EDT
Created attachment 305674 [details]
Patch to fix to correct units.
Comment 2 Josh Boyer 2008-05-16 07:20:34 EDT
Which site did you go to?  www.lesswatts.org works just fine, and I did an svn
update of the project this morning.
Comment 3 Jindrich Novy 2008-05-16 13:35:05 EDT
I was trying http://www.linuxpowertop.org/ since I found that one in the spec.
It  resolves fine now, but it didn't at the time I tried this morning.

Also the http://mail.lesswatts.org/mailman/listinfo/discuss didn't work but
works now. Both things work for me now, so I'll post the patch also to upstream.
Comment 4 Bug Zapper 2008-11-25 21:16:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-11-18 07:30:03 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-12-18 01:08:52 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.