This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446858 - suspend/resume on Dell Latitude D630 not working
suspend/resume on Dell Latitude D630 not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 10:31 EDT by Stefan Neufeind
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-11 09:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-05-16 10:31:06 EDT
idea for this "fix"/workaround came from bug #446807

Dell Latitude D630-laptop with Nvidia Quadro NVS 135M graphics and proprietary
driver-package 173.08-01 provided by livna (as well as an -ignoreABI-workaround)

Using Fedora 8 (until latest kernels before upgrade) on my Dell Latitude
D630-laptop worked fine.

Resume broke sind upgrading to Fedora 9. Tried with kernels 2.6.25-14 and
kernel-2.6.25.3-18.

When choosing suspend-to-ram from KDE (kpowersave) laptop suspends, but screen
stays blank after powering up again.

Additional info:
The issue is the entry in the following file:
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi

<match key="system.hardware.product"
contains_outof="D600;D610;D630">
        <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
        <merge key="power_management.quirk.vbemode_restore" type="bool">true</merge>
        <merge key="power_management.quirk.no_fb" type="bool">true</merge>
</match>

which sets the three quirks.

Alt least for my D630 this is wrong. My D630 suspends and resumes (and btw.
 hiberates) perfectly if these quirks are NOT set. I just removed the match for
D630.
Comment 1 Stefan Neufeind 2008-05-17 16:49:37 EDT
Hmm, worked three times when I tried. But can't get it to work anymore :-(

So please rate this as "not yet fixed".

Symptom:
When the system returns from resume there is a blinking text-cursor. I can
Shift-F1 to the first text-console without a problem. But trying to Shift-F7 to
the graphic console does not work.

Maybe related to the Nvidia-driver 173.08?
Comment 2 Richard Hughes 2008-05-30 07:42:24 EDT
Don't use the closed source nvidia driver if you expect resume to work.
Comment 3 Stefan Neufeind 2008-07-16 11:02:46 EDT
As long as "nv" does not support my external monitor (DVI-connection) as well as
decent graphics-speed and as long as "nouveau" does not recognise the card at
all, unfortunately that seems to be no option :-(

PS: Currently trying with latest 173.14.09 ...
Comment 4 Scott Glaser 2009-04-09 14:09:30 EDT
Stefan,
Are you still running Fedora 9, or have you upgraded to 10 or Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Stefan Neufeind 2009-04-11 05:25:07 EDT
Meanwhile using Fedora 10, no "big" problems with suspend anymore. Sometimes I get sound-hickups upon resume (having a ticket open refering to pulseaudio) or my wifi (iwlagn) doesn't come up clean. But those are cases I can live with or that we can track in separate issues. So from my point of view, maybe mark this as closed.
Comment 6 Scott Glaser 2009-04-11 09:06:49 EDT
Stefan,
Thank you for your rapid response to my request for information. Based you your latest comment I will be closing this bug as fixed. Should you experience any further issues with suspend/resume that you can attribute to the hal component please feel free to open a new bug under the current version of that component.


CLOSED: ERRATA

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.