Bug 446862 - BLT graphics not functional in fedora 9
BLT graphics not functional in fedora 9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: blt (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Sergio Pascual
Fedora Extras Quality Assurance
:
: 447690 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 10:45 EDT by Sergio Pascual
Modified: 2008-07-26 01:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.4-28.z.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 00:38:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Pascual 2008-05-16 10:45:27 EDT
Description of problem
I was testing ds9 in fedora 9. The version  of ds9 in f8 and f9 is  ds9-5.1-4
In f9 ds9 fails to start with the following message:

Error in startup script: invalid command name "blt::graph"
    while executing
"blt::graph $ds9(main).horz  -title {}  -width $canvas(width) -height
$graph(size)  -takefocus 0  -bd 0 -relief flat  -rightmargin $graph(gap,x)
-leftm..."
    (procedure "CreateGraphs" line 7)
    invoked from within
"CreateGraphs"
    (file "/usr/share/ds9/src/ds9.tcl" line 1514)

After some research, I found this page: http://wiki.tcl.tk/199
It says that loading BLT after Tk loads the full interface (including
blt::graph) but loading alone loads only BLTLite, with only the commands that
can be used in tcl.


But with  blt 2.4 these are my results:
promt> tclsh
 % package require BLT
 2.4
 % info commands blt::*
 ::blt::tree ::blt::crc32 ::blt::bltdebug ::blt::bgexec ::blt::spline
::blt::vector ::blt::watch


promt> tclsh
 % package require Tk
 8.5.1
 % package require BLT
 2.4
 % info commands blt::*
 ::blt::tree ::blt::crc32 ::blt::bltdebug ::blt::bgexec ::blt::spline
::blt::vector ::blt::watch

I get the same commands, no clue of blt::graph
Comment 1 Sergio Pascual 2008-05-18 17:07:54 EDT
Some more testing. I've been testing the demos in the demo dir of blt. They seem
to work in fedora 8 with tcl 8.4, but they don't work in fedora 9.
Just one example, spline.tcl fails with this output:

Error in startup script: unknown namespace in import pattern "blt::tile::*"
    while executing
"namespace import -force blt::tile::*"
    invoked from within
"if { $tcl_version >= 8.0 } {
    namespace import blt::*
    namespace import -force blt::tile::*
}"
    (file "./spline.tcl" line 23)

Definitively, there's something wrong with blt in fedora 9
Comment 2 Sergio Pascual 2008-05-21 03:39:13 EDT
*** Bug 447690 has been marked as a duplicate of this bug. ***
Comment 3 Sergio Pascual 2008-05-21 03:41:45 EDT
Changing severity to high, as this breaks ds9 in fedora 9
Comment 4 Takanori MATSUURA 2008-05-26 03:27:55 EDT
Is this site helps us?

http://reddog.s35.xrea.com/wiki/A%20Stub-enabled%20BLT2.4z%20for%20Windows.html
Comment 5 Takanori MATSUURA 2008-05-26 03:29:21 EDT
Or this site?
http://jos.decoster.googlepages.com/bltfortk8.5.2
Comment 6 Sergio Pascual 2008-05-27 04:32:41 EDT
Compilation of  the tarball from #5 failled.

There's also a new blt version 3.0 in sourceforge's blt cvs. I could compile it,
but it isn't working nonetheless.
Comment 7 Sergio Pascual 2008-05-29 18:48:07 EDT
I have managed to build the code from #5. I'm going to produce a patch and
create a new release of blt
Comment 8 Fedora Update System 2008-05-29 18:54:16 EDT
blt-2.4-28.z.fc9 has been submitted as an update for Fedora 9
Comment 9 Fedora Update System 2008-05-30 22:12:40 EDT
blt-2.4-28.z.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4710
Comment 10 Takanori MATSUURA 2008-06-02 22:17:34 EDT
I have tested blt-2.4-28.z.fc9 and basically works fine.
But some examples and demos returns segmentation fault.

We hope newer version of BLT which supports Tcl/Tk 8.5 will be released.

Many thanks.
Comment 11 Fedora Update System 2008-06-11 00:38:25 EDT
blt-2.4-28.z.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-07-26 01:55:11 EDT
blt-2.4-28.z.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.