Bug 446875 - nv module: 8800 GTX failes to show image properly
nv module: 8800 GTX failes to show image properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
9
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 11:05 EDT by The Source
Modified: 2008-05-28 18:32 EDT (History)
0 users

See Also:
Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 18:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2008-05-16 11:05:19 EDT
Description of problem:
I see only black screen and switching to other consoles does not work. I can
only reboot with ctrl+alt+del. I tried to start anaconda manually from rescue
mode with --xdriver=vesa -G -m INSTALL, but anaconda launched that way crashes
after boot loader configuration screen. I don't want to install in text mode.
While nv is not fixed is there a way I can run anaconda properly with vesa
driver? Install media loader option maybe?

Version-Release number of selected component (if applicable):
F9 install media.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 The Source 2008-05-20 12:06:20 EDT
I read that F9 will be rereleased when bug with Russina translation anaconda is
fixed. But nv problem is much harder to avoid. Will rerelease contain a fix for nv?
Comment 2 Matěj Cepl 2008-05-20 18:06:12 EDT
If you just xdriver=vesa on the command line, what happens?

If the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and cp
/tmp/X* to some other place -- USB stick, some other computer via network, some
on the Internet, and please attach it to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 The Source 2008-05-20 23:30:21 EDT
well, there's a problem:
1. I can't run anaconda from command line - it crashes on method string parsing
(I tried the string anaconda authors suggested - no luck). I already reported
this bug.
2. Anaconda doesn't crash because of nv. It just shows black screen. And the
worst thing that I can't even switch to another console - they are blackened
too. I can only switch to another (invisible) console and press Ctrl+Alt+Del to
reboot.
Comment 4 The Source 2008-05-21 02:28:03 EDT
Ok, xdriver=vesa option passed in boot loader solved the installation problem. I
will try to get Xorg log with nv module on installed system now.
Comment 5 The Source 2008-05-28 12:07:36 EDT
Can not reproduce on installed system. Tried many times. Perhaps updating kernel
to 2.6.25.3 solved the problem.
Comment 6 Matěj Cepl 2008-05-28 18:32:23 EDT
Wonderful, thanks for letting us know. And yes, there were many many updates
(actually too many for my taste) after GA, so it is quite possible that your bug
got fixed meantime.

Note You need to log in before you can comment on or make changes to this bug.