Bug 446882 - Problems in intel driver (Xorg)
Problems in intel driver (Xorg)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-05-16 11:20 EDT by Alan Matsuoka
Modified: 2010-10-22 21:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:28:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
displaytests.tgz (91.60 KB, application/x-compressed-tar)
2008-05-16 11:20 EDT, Alan Matsuoka
no flags Details
fscb17-1t7k03_t61_open.txt from the attachment 305697 (474 bytes, text/plain)
2008-05-16 17:58 EDT, Matěj Cepl
no flags Details
lg1800p202kg_x61.txt from the attachment 305697 (980 bytes, text/plain)
2008-05-16 17:58 EDT, Matěj Cepl
no flags Details
lg1800p206kg.txt from the attachment 305697 (980 bytes, text/plain)
2008-05-16 17:58 EDT, Matěj Cepl
no flags Details
lg1800p206kg_t61_open.txt from the attachment 305697 (559 bytes, text/plain)
2008-05-16 17:58 EDT, Matěj Cepl
no flags Details
xorg.0.log_eizol985ex_t61_lid_open.log from the attachment 305697 (86.00 KB, text/plain)
2008-05-16 17:59 EDT, Matěj Cepl
no flags Details
xorg.0.log_fscb17-1t7k03_t61_lid_open.log from the attachment 305697 (83.86 KB, text/plain)
2008-05-16 17:59 EDT, Matěj Cepl
no flags Details
xorg.0.log_fscx180FG500_x61.log from the attachment 305697 (93.04 KB, text/plain)
2008-05-16 17:59 EDT, Matěj Cepl
no flags Details
xorg.0.log_lg1800p202kg_esprimo.log from the attachment 305697 (29.31 KB, text/plain)
2008-05-16 17:59 EDT, Matěj Cepl
no flags Details
xorg.0.log_lg1800p202kg_x61.log from the attachment 305697 (42.81 KB, text/plain)
2008-05-16 18:00 EDT, Matěj Cepl
no flags Details
xorg.0.log_lg1800p206kg_t61_lid_open.log from the attachment 305697 (203.85 KB, text/plain)
2008-05-16 18:00 EDT, Matěj Cepl
no flags Details
xorg.0.log_lg1800p206kg_x61.log from the attachment 305697 (79.10 KB, text/plain)
2008-05-16 18:00 EDT, Matěj Cepl
no flags Details
x log for X61 and viewsonic VX2025wm (58.94 KB, text/plain)
2008-12-03 12:00 EST, Cameron Meadors
no flags Details
xrandr output for X61 with VX2025wm (1.08 KB, text/plain)
2008-12-03 12:01 EST, Cameron Meadors
no flags Details

  None (edit)
Description Alan Matsuoka 2008-05-16 11:20:42 EDT
Description of problem:

This is the comment in IT 124575, describing the problems LVM still has with the
intel driver:

--snip
We have now the results of the final tests available. Because there were so many
faults in the different tests I made some additional testings based on the
unique test results:

1. X starts with the correct resolution (1280x1024) but xrandr /
gnome-display-properties shows resolutions  up to 1600x1024. I have captured
this in: xorg.0.log_lg1800p202kg_x61.log and lg1800p202kg_x61.txt as well as
xorg.0.log_lg1800p206kg_x61.log

2. X starts with a wrong resolution 1280x786 and the user can't set the correct
one. I have seen this on the Esprimo: xorg.0.log_lg1800p202kg_esprimo.log

3. X starts with a wrong resolution 1280x800. This is with different displays on
the T61 with lid open. Logfiles are: xorg.0.log_lg1800p206kg_t61_lid_open.log,
xorg.0.log_eizol985ex_t61_lid_open.log and
xorg.0.log_fscb17-1t7k03_t61_lid_open.log. Output of xrandr is in
fscb17-1t7k03_t61_open.txt.

Regarding the black screen phenomenon we have seen very often I can report that
with Option "modedebug" "on"
I never have seen this. Without this option we ran into this problem in most of
the display tests.
I did an crosscheck and disbled the option in xorg.conf but I was not able to
reproduce this problem. I had also removed the battery pack from my laptop.
After the next reboot I got the black screen.... At the moment
we can live with the "modedebug on" as workaround.

-- Hans-Gerd

--snip

How reproducible:

persistent

Steps to Reproduce:

see IT 124575 and attachments

Additional info:

original IT is 124575
Comment 1 Alan Matsuoka 2008-05-16 11:20:42 EDT
Created attachment 305697 [details]
displaytests.tgz
Comment 2 Matěj Cepl 2008-05-16 17:58:29 EDT
Created attachment 305761 [details]
fscb17-1t7k03_t61_open.txt from the attachment 305697 [details]
Comment 3 Matěj Cepl 2008-05-16 17:58:38 EDT
Created attachment 305762 [details]
lg1800p202kg_x61.txt from the attachment 305697 [details]
Comment 4 Matěj Cepl 2008-05-16 17:58:47 EDT
Created attachment 305763 [details]
lg1800p206kg.txt from the attachment 305697 [details]
Comment 5 Matěj Cepl 2008-05-16 17:58:56 EDT
Created attachment 305764 [details]
lg1800p206kg_t61_open.txt from the attachment 305697 [details]
Comment 6 Matěj Cepl 2008-05-16 17:59:12 EDT
Created attachment 305765 [details]
xorg.0.log_eizol985ex_t61_lid_open.log from the attachment 305697 [details]
Comment 7 Matěj Cepl 2008-05-16 17:59:29 EDT
Created attachment 305766 [details]
xorg.0.log_fscb17-1t7k03_t61_lid_open.log from the attachment 305697 [details]
Comment 8 Matěj Cepl 2008-05-16 17:59:47 EDT
Created attachment 305767 [details]
xorg.0.log_fscx180FG500_x61.log from the attachment 305697 [details]
Comment 9 Matěj Cepl 2008-05-16 17:59:58 EDT
Created attachment 305768 [details]
xorg.0.log_lg1800p202kg_esprimo.log from the attachment 305697 [details]
Comment 10 Matěj Cepl 2008-05-16 18:00:08 EDT
Created attachment 305769 [details]
xorg.0.log_lg1800p202kg_x61.log from the attachment 305697 [details]
Comment 11 Matěj Cepl 2008-05-16 18:00:28 EDT
Created attachment 305770 [details]
xorg.0.log_lg1800p206kg_t61_lid_open.log from the attachment 305697 [details]
Comment 12 Matěj Cepl 2008-05-16 18:00:44 EDT
Created attachment 305771 [details]
xorg.0.log_lg1800p206kg_x61.log from the attachment 305697 [details]
Comment 13 Matěj Cepl 2008-05-16 18:02:03 EDT
Comment on attachment 305697 [details]
displaytests.tgz

we prefer all files unpacked and separate
Comment 19 Adam Jackson 2008-09-19 10:28:22 EDT
1.6.5-9.15.el5 has been rebuilt against the new randr sources, which should at least make things fail differently.

Moving to MODIFIED.
Comment 22 Cameron Meadors 2008-12-03 11:59:55 EST
I tested on snap4 x86_64 on a X61 with ViewSonic VX2025wm external monitor.  I still see the same issue.  The correct mode is used, but xrandr and gnome-display-properties still shows modes that do not work.  I will attach x log and xrandr output.
Comment 23 Cameron Meadors 2008-12-03 12:00:49 EST
Created attachment 325562 [details]
x log for X61 and viewsonic VX2025wm
Comment 24 Cameron Meadors 2008-12-03 12:01:52 EST
Created attachment 325563 [details]
xrandr output for X61 with VX2025wm
Comment 26 Adam Jackson 2008-12-04 09:46:45 EST
Which ones don't work?
Comment 27 Cameron Meadors 2008-12-04 09:55:08 EST
Neither of the 1920x modes worked.  I spot checked mode smaller that 1680 and they worked.  I can do a more thorough test of all the modes.
Comment 28 Adam Jackson 2008-12-04 16:15:38 EST
This is going to be awkward.  We can avoid adding the default mode set to the list if the monitor doesn't claim to be continuous-frequency, but some do and some don't.  And there's no really good way to know the size of the monitor in pixels, so we can't necessarily just toss bigger modes out.

Hmm.
Comment 30 Adam Jackson 2008-12-10 14:57:51 EST
Already built as xorg-x11-drv-i810-1.6.5-9.21.el5

MODIFIED
Comment 33 errata-xmlrpc 2009-01-20 16:28:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0160.html

Note You need to log in before you can comment on or make changes to this bug.