Bug 446883 - compilation errors
compilation errors
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dayplanner (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Krzysztof Kurzawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 11:20 EDT by lm
Modified: 2008-09-10 03:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 03:14:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lm 2008-05-16 11:20:44 EDT
Description of problem:
i launched the application without effect. 

so, i tryed to launch the application from terminal and here it is the output i had:

$ dayplanner
Locale::gettext is not available. This will work, but localization will *not* be
available
syntax error at /usr/share/dayplanner/dayplanner-daemon line 116, near "SOCK_STREAM
                        Timeout"
syntax error at /usr/share/dayplanner/dayplanner-daemon line 509, near "SOCK_STREAM
                                                        Timeout"
Execution of /usr/share/dayplanner/dayplanner-daemon aborted due to compilation
errors.
syntax error at /usr/bin/dayplanner-daemon line 116, near "SOCK_STREAM
                        Timeout"
syntax error at /usr/bin/dayplanner-daemon line 509, near "SOCK_STREAM
                                                        Timeout"
Execution of /usr/bin/dayplanner-daemon aborted due to compilation errors.
*** (Day Planner 0.8.1) Warning: Unable to start daemon!
Died at /usr/bin/dayplanner line 5376.
Comment 1 Christoph Wickert 2008-07-06 20:26:15 EDT
Krzysztof, please add

  Requires:       perl(Locale::gettext)

and update to 0.9.1 which will fix this crash. TIA!
Comment 2 Christoph Wickert 2008-07-14 10:01:06 EDT
Krzysztof, any plans?
Comment 3 Christoph Wickert 2008-07-18 21:38:56 EDT
In order to fix this bug I updated to 0.9.1 now on F-9 and devel. Also
BuildRequires perl(Locale::gettext)

Krzysztof, PLEASE respond to this bug within 2 weeks, otherwise you are
considered missing in action.
Comment 4 Fedora Update System 2008-07-18 21:42:14 EDT
dayplanner-0.9.1-1.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-07-23 03:13:38 EDT
dayplanner-0.9.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dayplanner'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6625
Comment 6 Fedora Update System 2008-07-24 09:03:38 EDT
dayplanner-0.9.1-2.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-07-24 20:18:18 EDT
dayplanner-0.9.1-3.fc9 has been submitted as an update for Fedora 9
Comment 8 Krzysztof Kurzawski 2008-08-19 13:25:28 EDT
Sorry, but I was on holiday and I hadn't time. I decided to orphane some package:
    
     * dayplanner -- An easy and clean Day Planner
     * jabbin -- Instant messaging and VoIP Jabber client
     * taskcoach -- Your friendly task manager

If someone is interesting please contact me.

Cheers,
Krzysztof
Comment 9 Fedora Update System 2008-09-10 03:14:53 EDT
dayplanner-0.9.1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.