Bug 4469 - "kppp" of KDE suid bit is not set during installation
Summary: "kppp" of KDE suid bit is not set during installation
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 4684 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-11 02:22 UTC by prabirm
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 00:06:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description prabirm 1999-08-11 02:22:03 UTC
This has to be done manually. Otherwise a non-root
user cannot run "kppp". I had to do the follwoing:

chmod +s {$KDEPATH}/bin/kppp (as root) to make it work.

Isn't it a good idea to do this during installation ?

I am using rawhide released on 4th August, 19999.

Regards
Prabir

Comment 1 Cristian Gafton 1999-08-24 00:59:59 UTC
assigned to pbrown

Comment 2 Preston Brown 1999-08-29 16:24:59 UTC
*** Bug 4684 has been marked as a duplicate of this bug. ***

Within the latest KDE rpm for kdenetwork
(kdenetwork-1.1.1-1), the proper permissions for kppp are
not set. This program should be suid root; as currently set,
kppp fails to execute properly. Manually changing the
permissions corrected the trouble; however, this should be
handled during the installation process.

Comment 3 Michael K. Johnson 1999-09-20 00:06:59 UTC
It will be done a bit differently; in our next release it will ask
you for your root password when it starts up instead of being setuid
root.

Comment 4 Gene Czarcinski 1999-09-24 16:03:59 UTC
Thank you.  This makes sense.  Ater griping about this and being told
"too bad" I find this a good solution.

If you look at the code, you will find it is quite good at attempting
to limit the exposure.  However, without getting root in some manner,
kppp is useless.

Thanks, Gene


Note You need to log in before you can comment on or make changes to this bug.