Bug 446914 - PAN package fails to re-build on Fedora 9
PAN package fails to re-build on Fedora 9
Status: CLOSED DUPLICATE of bug 433970
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Alexander Dalloz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 12:42 EDT by Pavel Polischouk
Modified: 2008-05-21 14:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 14:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch fixing PAN compilation: missing includes (5.15 KB, patch)
2008-05-16 12:42 EDT, Pavel Polischouk
no flags Details | Diff

  None (edit)
Description Pavel Polischouk 2008-05-16 12:42:14 EDT
Description of problem:
PAN 0.132 code is incompatible with GCC 4.3.0, mostly failing to include the
needed system headers.

Version-Release number of selected component (if applicable):
pan-0.132-2.fc8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild pan-0.132-2.fc8.src.rpm
2. Observe compilation errors
  
Actual results:
Multiple compilation errors, mostly due to missing #include <stdlib.h> and other
system headers.

Expected results:
Should re-build properly.

Additional info:
Attached the patch to fix the compilation
Comment 1 Pavel Polischouk 2008-05-16 12:42:14 EDT
Created attachment 305708 [details]
A patch fixing PAN compilation: missing includes
Comment 2 Pavel Polischouk 2008-05-16 13:56:33 EDT
Debugged the problem further. It happens when trying to load a huge tasks.nzb
(around 95000 lines). When the file is split into two parts by copying and
removing extra <file>...</file> sections, each part loads successfully.
This most likely means state corruption in nzb parser by certain input.
Comment 3 Pavel Polischouk 2008-05-21 14:36:06 EDT
Please disregard the previous comment, added it here by mistake instead of
another bug.
Comment 4 Pavel Polischouk 2008-05-21 14:50:08 EDT

*** This bug has been marked as a duplicate of 433970 ***

Note You need to log in before you can comment on or make changes to this bug.