Bug 446929 - convert hangs when creating PDF from jpegs
convert hangs when creating PDF from jpegs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ImageMagick (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Horak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 13:11 EDT by Brian Wheeler
Modified: 2015-06-01 08:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 07:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A test file which is known to fail (13.34 KB, image/jpeg)
2008-05-16 13:11 EDT, Brian Wheeler
no flags Details
strace of convert apfelkuchen.jpg apfelkuchen.pdf (37.48 KB, text/plain)
2008-07-17 15:07 EDT, Ralph Angenendt
no flags Details

  None (edit)
Description Brian Wheeler 2008-05-16 13:11:18 EDT
Description of problem:

convert hangs when trying to convert jpegs to pdf.

Version-Release number of selected component (if applicable):

ImageMagick.x86_64                       6.2.8.0-4.el5_1.1      installed       
ImageMagick.i386                         6.2.8.0-4.el5_1.1      installed       
ImageMagick-c++.i386                     6.2.8.0-4.el5_1.1      installed       
ImageMagick-c++.x86_64                   6.2.8.0-4.el5_1.1      installed       
ImageMagick-c++-devel.i386               6.2.8.0-4.el5_1.1      installed       
ImageMagick-c++-devel.x86_64             6.2.8.0-4.el5_1.1      installed       
ImageMagick-devel.x86_64                 6.2.8.0-4.el5_1.1      installed       
ImageMagick-devel.i386                   6.2.8.0-4.el5_1.1      installed       
ImageMagick-perl.x86_64                  6.2.8.0-4.el5_1.1      installed   

How reproducible:

every time

Steps to Reproduce:
1. "convert earthquake_chess.jpg earthquake_chess.jpg  test.pdf"
2. wait way longer than it should take
3. hit ctrl-c
4. get corrupted pdf
  
Actual results:

convert hangs

Expected results:

convert completes

Additional info:

This works fine with other image types, and works ok when I tested it using the
6.3.8 version on my Fedora 9 box.
Comment 1 Brian Wheeler 2008-05-16 13:11:18 EDT
Created attachment 305712 [details]
A test file which is known to fail
Comment 2 Ralph Angenendt 2008-07-17 15:04:57 EDT
Still doesn't work in 5.2, same version of ImageMagick.

Comment 3 Ralph Angenendt 2008-07-17 15:07:21 EDT
Created attachment 312075 [details]
strace of convert apfelkuchen.jpg apfelkuchen.pdf

strace of convert apfelkuchen.jpg apfelkuchen.pdf

convert hangs in futex(0x157d7590, FUTEX_WAIT, 2, NULL), the interrupt comes
from me killing the hanging process.
Comment 4 RHEL Product and Program Management 2014-03-07 08:39:49 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-03 07:41:35 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 6 Brian Wheeler 2015-06-01 08:03:06 EDT
bug has long since closed, but I'm still getting needinfo reminders.  hopefully this will clear it.

Note You need to log in before you can comment on or make changes to this bug.