Bug 446940 - ocaml / omake failing with 34 GB problem
ocaml / omake failing with 34 GB problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ocaml (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 14:08 EDT by Richard W.M. Jones
Modified: 2008-05-28 22:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.9.8.5-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 22:34:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of omake failing (30.94 KB, text/plain)
2008-05-16 15:15 EDT, shiv
no flags Details

  None (edit)
Description Richard W.M. Jones 2008-05-16 14:08:34 EDT
omake fails with suspected 34 GB problem which we thought was fixed in bug 445545.

(Originally reported by Shivkumar Chandrasekaran).
Comment 1 shiv 2008-05-16 15:15:13 EDT
Created attachment 305726 [details]
strace of omake failing

This is just output of strace executing 'omake clean' on my project. This
worked flawlessly in Core 8 with Godi installed omake.
Comment 2 shiv 2008-05-16 15:19:22 EDT
[shiv@sobolev CamlFloat]$ rpm -qa | grep ocaml
ocaml-runtime-3.10.1-3.fc9.x86_64
ocaml-omake-0.9.8.5-2.fc9.x86_64
ocaml-3.10.1-3.fc9.x86_64
Comment 3 Richard W.M. Jones 2008-05-16 16:05:59 EDT
The 'strace' indicates that the process isn't running the patched runtime, which
is because I didn't recompile omake with the new runtime (so it's using the old one).

I'll push a new build of omake to F9 which should fix this shortly.

Comment 4 Richard W.M. Jones 2008-05-16 16:25:13 EDT
Hmm, by 'shortly' I mean after ocaml-3.10.1-3 has moved to stable,
so probably tomorrow.
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-3740

Some alternatives if you're impatient:
(1) Enable the development repository and pull ocaml 3.10.2 +
omake 0.9.8.5-3 which is built with the fix.

(2) Grab the SRPM of ocaml-omake and rebuild it:
  yum install yum-utils rpm-build
  yumdownloader --source ocaml-omake
  rpmbuild -ba ocaml-omake-*.src.rpm

Comment 5 Fedora Update System 2008-05-17 11:03:59 EDT
ocaml-omake-0.9.8.5-3.fc9 has been submitted as an update for Fedora 9
Comment 6 Richard W.M. Jones 2008-05-17 11:06:02 EDT
OK, I've rebuilt ocaml-omake and the new package (0.9.8.5-3) will be
pushed to F-9 updates-testing shortly.

http://koji.fedoraproject.org/koji/taskinfo?taskID=614844
https://admin.fedoraproject.org/updates/F9/pending/ocaml-omake-0.9.8.5-3.fc9

Comment 7 Fedora Update System 2008-05-21 07:05:46 EDT
ocaml-omake-0.9.8.5-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ocaml-omake'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4262
Comment 8 Fedora Update System 2008-05-28 22:34:38 EDT
ocaml-omake-0.9.8.5-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.