Bug 447015 - Wrong default mirrorlist for "Additional Fedora Software"
Wrong default mirrorlist for "Additional Fedora Software"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-05-16 19:20 EDT by Alex CONRAD
Modified: 2008-06-21 16:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 16:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex CONRAD 2008-05-16 19:20:26 EDT
Description of problem:
During the wizard installation, during package selection, we can select
"Additional Fedora Software" as an additional repository. Althought, the
mirrorlist provided is:

  http://mirrors.fedoraproject.org/mirrorlist?repo=9&arch=i386

and it should be:

  http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-9&arch=i386

(missing the "fedora-" part)

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. Check the "Additional Fedora Software"
2. It will propose to enable network, OK.
3. After a short time, we get an error back.
  
Actual results:

"""
Unable to read package metadata from repository. This may be due to a missing
repodata directory. Please ensure that your repository has been correctly generated.

Error getting reposiroty data for AdditionalFedoraSoftware, repository not found
"""

Expected results:

Show me the packages...

Additional info:

... so I can install the missing XFCE packages from the DVD.
Comment 1 Alex CONRAD 2008-05-16 20:04:46 EDT
Should I open a bug for not being able to change the link? It seems that once
the error has shown up, even if I edit the link, I get the error back instantly
(it won't try to connect again). So I needed to create a new repository with the
correct link.

Regards,
Alex Conrad
Comment 2 Jeremy Katz 2008-05-19 11:22:01 EDT
Blargh.  mdomsch -- is there any chance we can get mirrormanager to handle this
url so that we don't have people continuing to hit this over the life of F9? :-/
Comment 3 Matt Domsch 2008-05-19 16:00:00 EDT
Done.  MirrorManager now has a redirect in place, so requests to 'repo=9' will 
be sent to 'repo=fedora-9' content.

<RepositoryRedirect 91L fromRepo=u'9' toRepo=u'fedora-9'>
Comment 4 Jeremy Katz 2008-05-19 16:02:47 EDT
And we'll do something to fix things properly for F10
Comment 5 Chris Lumens 2008-05-30 15:01:04 EDT
I've committed my stuff for using the /etc/yum.repos.d files to anaconda so this
should be better in time for the first test release of F10.

Note You need to log in before you can comment on or make changes to this bug.