Bug 447017 - Updated rdesktop has additional dependencies, unresolved
Summary: Updated rdesktop has additional dependencies, unresolved
Alias: None
Product: Fedora
Classification: Fedora
Component: rdesktop
Version: 9
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2008-05-16 23:30 UTC by Stephen Cuppett
Modified: 2013-03-06 03:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2009-06-10 11:47:12 UTC

Attachments (Terms of Use)

Description Stephen Cuppett 2008-05-16 23:30:06 UTC
Description of problem:

On Fedora 9, x86_64, an updated rdesktop cannot be downloaded because of an
unresolved dependency to libcrypto.

I tried removing the original package with:

rpm -e kdenetwork rdesktop and tried installing again; however, it's still failing:

[root@home init.d]# yum install rdesktop
Loaded plugins: priorities, refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package rdesktop.x86_64 0:1.6.0-1.fc8 set to be updated
--> Processing Dependency: libcrypto.so.6()(64bit) for package: rdesktop
--> Finished Dependency Resolution
rdesktop-1.6.0-1.fc8.x86_64 from updates has depsolving problems
  --> Missing Dependency: libcrypto.so.6()(64bit) is needed by package
rdesktop-1.6.0-1.fc8.x86_64 (updates)
Error: Missing Dependency: libcrypto.so.6()(64bit) is needed by package
rdesktop-1.6.0-1.fc8.x86_64 (updates)

How reproducible:

Every time Fedora 9 has tried to update and today trying to install the latest
from the repos... for the last couple days.
Actual results:

rdesktop fails to install or update with unresolved dependency.

Expected results:

rdesktop should be able to update or install correctly using same repos as
enabled before.

Additional info:

Comment 1 Stephen Cuppett 2008-05-16 23:32:04 UTC
I have fedora, fedora-updates and livna repos enabled.

Comment 2 Bug Zapper 2009-06-10 00:55:00 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Note You need to log in before you can comment on or make changes to this bug.