Bug 447039 - Kernel oops related to pcsp for 2.6.26-0.13.rc2.git5
Kernel oops related to pcsp for 2.6.26-0.13.rc2.git5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 06:54 EDT by Joachim Frieben
Modified: 2008-06-05 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 19:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg-2.6.26-0.13.rc2.git5.fc10.x86_64.txt with backtrace (37.30 KB, text/plain)
2008-05-17 06:54 EDT, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 10701 None None None Never

  None (edit)
Description Joachim Frieben 2008-05-17 06:54:05 EDT
Description of problem:
After upgrading to kernel 2.6.26-0.13.rc2.git5.fc10.x86_64, system
sounds are gone. Instead, one can hear corresponding clicks emanating
from the PC speaker. dmesg reveals a backtrace which appears to be
related to this issue.

Version-Release number of selected component (if applicable):
kernel-2.6.26-0.13.rc2.git5.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to kernel-2.6.26-0.13.rc2.git5.fc10.x86_64
2. Reboot system.
3. Start GNOME session.
  
Actual results:
Click sounds from the PC speaker accompany system events.

Expected results:
GNOME sounds are played by the sound system.

Additional info:
- gnome-volume-control shows that the current audio device is pcsp.
- PulseAudio version is 0.9.10-1.fc9.
- ALSA version is 1.0.16-3.fc10.
Comment 1 Joachim Frieben 2008-05-17 06:54:05 EDT
Created attachment 305797 [details]
dmesg-2.6.26-0.13.rc2.git5.fc10.x86_64.txt with backtrace
Comment 2 Joachim Frieben 2008-05-17 07:15:49 EDT
Sound works again correctly with kernel-2.6.25.4-23.fc9.x86_64.
Comment 3 Dave Jones 2008-05-17 12:49:52 EDT
hmm, probably the addition of an ALSA driver for the PC speaker. This seems kind
of pointless, so I'll just turn it off.

Please check again with a build equal to or higher than
2.6.26-0.14.rc2.git5.fc10 when that appears.

Thanks.
Comment 4 Joachim Frieben 2008-05-17 13:08:37 EDT
PC speaker support actually sounds nice. Shouldn't this issue be dealt
with upstream then? I don't mind opening a new bug report over there.
Comment 5 Dave Jones 2008-05-17 13:27:17 EDT
Is this really useful ? From the Kconfig..

          If you don't have a sound card in your computer, you can include a
          driver for the PC speaker which allows it to act like a primitive
          sound card.

It's hard to imagine a machine without a sound card these days, given they
typically come onboard.  Hmm, though I suppose it's useful if you have a speaker
in your PC, and no external speakers.  The one concern I have is that adding
this driver will mean that everyone typically gets two ALSA output sources, and
which one gets picked by default is probably down to which driver gets loaded
first.  For a lot of people, that would be annoying if suddenly their music
comes out of their PC instead of their speakers.  Adding Lennart to the Cc,
perhaps he has some ideas on how to avoid that situation.

Another annoyance, is that this driver is unlikely to work well during some
periods of fedora development due to this..

#ifdef CONFIG_DEBUG_PAGEALLOC
        /* Well, CONFIG_DEBUG_PAGEALLOC makes the sound horrible. Lets alert */
        printk(KERN_WARNING "PCSP: CONFIG_DEBUG_PAGEALLOC is enabled, "
               "which may make the sound noisy.\n");
#endif

(We enable that option from time to time, though the build you tried didn't have
it turned back on yet).

I'll forward the backtrace upstream.
Comment 6 Joachim Frieben 2008-05-18 06:20:00 EDT
Bug filed upstream at http://bugzilla.kernel.org/show_bug.cgi?id=10701
Comment 7 Joachim Frieben 2008-05-18 10:57:24 EDT
Both audio devices register correctly on my system:

  card0/  cards   devices  oss/  pcsp@  timers
  card1/  CK804@  modules  pcm   seq/   version

It is furthermore possible to choose the default device by means of
gnome-sound-properties. So far, so good. It is definitely worthwile
to have some simple audio capability in case no external speakers
are available. Notebooks are of cause exempted herefrom, but in
general, this appears to be a compelling feature.
The clicks that I have describe seem to be due to some deficiency of
the NForce chipset of my Tyan K8E mainboard. In general, you expect
at least system sounds to be reproduced in a reasonable manner.
Comment 8 Chuck Ebbert 2008-06-05 19:46:07 EDT
Upstream bug is closed as CODE_FIX.

Note You need to log in before you can comment on or make changes to this bug.