Bug 447042 - KDE 4 classic menu - right-clisk is left-click
KDE 4 classic menu - right-clisk is left-click
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 07:08 EDT by Mick Mearns
Modified: 2008-07-28 16:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 16:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mick Mearns 2008-05-17 07:08:31 EDT
Description of problem:when classic menu selected in KDE4.
Right-click on an app runs it, onleft click should do this.
The Kickoff menu does the correct thing.



Version-Release number of selected component (if applicable):
KDE 4, FC9 fully updated

How reproducible:
constant

Steps to Reproduce:
1.right-click on the F (should be k?) change to classic menu
  left-click on F
2.select an app
3.right-click on it - runs
  
Actual results:
app runs

Expected results:
menu of actions

Additional info:
not sure on the Component field.
Comment 1 Kevin Kofler 2008-05-17 07:11:26 EDT
This is simply a feature which is not yet implemented, not a bug.
Comment 2 Mick Mearns 2008-05-17 16:49:27 EDT
more info:
The system was working fine, FC9 KDE4
Two users root and mick, only one console.

I logged in as mick.
I then started to copy a bunch of mp3 files from a portable player into my home.
This was done using two dolphin's.


The whole system dropped to it's knees, very very slow.
The xfer was about 1M/s

I closed all the windows - long delay between mouse clicks.
Finally in exasperation I unplugged the usb device.
The system came back but was slower than usual, so I rebooted.

When It came back up I noticed that icons in the taskbar would show a background
when clicked, but would not run the app.

Then I noticed the right-click problem.
The mailing list said to delete the .kde file in /home/mick

I tried just adding a new user - guest.

OK test:
root right-click classic - runs app
root right-click kickoff - OK

mick right-click classic - runs app
mick right-click kickoff - OK

guest right-click classic - OK
guest right-click kickoff - OK

taskbar:
root - bad
mick - bad
guest - OK

So it looks like a file problem, as a new user is fine.
I checked with dolphin when it first happened as mick.
I could not find any file hidden or not with a date/time even close to when it
happened.

(when I was a field engineer for Inforex - features were billable, bugs were free)
Comment 3 Mick Mearns 2008-05-17 18:10:31 EDT
Hi;
 deleted .kde from /home/mick (logged in as root)

logged in as mick.
Now the taskbar works, but the right-click classic bug is still there.
The kickoff right-click works
Comment 4 Kevin Kofler 2008-05-17 22:48:40 EDT
> guest right-click classic - OK

Are you sure this worked? If so, looks like we have an actual bug somewhere 
then. I thought this feature was simply not there.
Comment 5 Mike C 2008-06-14 05:56:10 EDT
In my f9 system in kde4 using the kickoff menu - under the options for right
click one should be able to choose to add to the desktop or add to the panel.

Add to desktop does indeed add an icon to the desktop, but add to panel also
puts an icon on the desktop and not onto the panel!

So there does seem to be a bug here for the kickoff menu... 

It would be nice to have the same facility (properly working) with the classic
menu at some point even if it is not yet currently implemented.
Comment 6 Mike C 2008-06-15 06:39:50 EDT
To add to comment #4 on my system in classic right click executes the
application, just the same as left click. It is not clear what the intended
action for right click is supposed to be?
Comment 7 Rex Dieter 2008-06-15 09:35:11 EDT
Afaik, kde4's classic menu has always treated left/right click as equivalent. ??
Comment 8 Steven M. Parrish 2008-06-21 14:34:03 EDT
Is this an issue or working as designed?
Comment 9 Ngo Than 2008-06-23 05:12:49 EDT
it's not working as designed, this feature isn't implemented yet.
Comment 10 Steven M. Parrish 2008-06-23 15:22:10 EDT
Based on comments this sounds like a bug.  I did check upstream and found no
matching bug. Please file upstream and then add upstream info to this report. 
We will monitor for a resolution.
Comment 11 Steven M. Parrish 2008-07-28 16:26:55 EDT
The information we've requested above is required in order
to review this problem report further and diagnose or fix the
issue if it is still present.  Since it has been thirty days or
more since we first requested additional information, we're assuming
the problem is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested,
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.