Bug 447059 - after F9 update and yum update, no more ntfs access
after F9 update and yum update, no more ntfs access
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
i686 Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-17 10:05 EDT by Landon Kelsey
Modified: 2008-05-17 20:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-17 18:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/fstab (662 bytes, text/plain)
2008-05-17 10:06 EDT, Landon Kelsey
no flags Details
snapshot...tried to mount ntfs in disk management (101.44 KB, image/jpeg)
2008-05-17 15:45 EDT, Landon Kelsey
no flags Details
snapshot showing ntfs and sdc1 (26.81 KB, image/jpeg)
2008-05-17 17:57 EDT, Landon Kelsey
no flags Details

  None (edit)
Description Landon Kelsey 2008-05-17 10:05:59 EDT
Description of problem:
after F9 update and yum update, no more ntfs access
my fstab (worked under F8) is changed

flash memory drive on USB 2 doesn't mount automatically 

once it was necessary to set up fstab for auto mount
I had it all worked out then
  are we back to that?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Landon Kelsey 2008-05-17 10:06:00 EDT
Created attachment 305805 [details]
Comment 2 Landon Kelsey 2008-05-17 15:45:40 EDT
Created attachment 305815 [details]
snapshot...tried to mount ntfs in disk management

tried to mount ntfs in disk management...message says something about /dev/sdc1
but that was the flash drive USB under F8

This was a Fedora 8->9 update
Comment 3 Tom "spot" Callaway 2008-05-17 15:50:45 EDT
Hmm, something odd is happening here. Did you use anaconda to do that update?

Can you use parted to print the partition tables? Lets find out what partition
has NTFS on it.

Comment 4 Landon Kelsey 2008-05-17 16:35:50 EDT
I did a simple(?) F9 update from F8. It was uneventful but after reboot, 

ntfs /media/Windows AND
mount of sdc1 (USB flash memory

both worked great under F8.

LMKIII (root) ~ [942]>parted
GNU Parted 1.8.8
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) check 1                                                          
Error: Partition /dev/sda1 is being used. You must unmount it before you modify
it with Parted.

Under F8 sda1 was the entry in fstab for ntfs on MS XP Prof and it worked great!
Comment 5 Landon Kelsey 2008-05-17 16:39:04 EDT
never had any luck with updates...In a few days I may do a straight install!

What worries me is that the message (see attached screen snapshot) concerning
the mounting of ntfs discusses sdc1 and that is the USB Flash memory stick!

The file fstab looks messed up!
Comment 6 Tom "spot" Callaway 2008-05-17 16:44:12 EDT
Don't do "check", just print.

For example, my disk:

[root@localhost ~]# parted /dev/sda
GNU Parted 1.8.8
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print                                                            
Model: ATA ST910021AS (scsi)
Disk /dev/sda: 100GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type     File system  Flags
 1      32.3kB  206MB  206MB   primary  ext3         boot 
 2      206MB   100GB  99.8GB  primary               lvm  

If you have more than one disk, cat /proc/partitions will give a list of all the
partitions it can see.
Comment 7 Landon Kelsey 2008-05-17 17:03:44 EDT
Thanks I learned something!
MS XP Prof is on sda1
F9 is on sdb

LMKIII (root) ~ [943]>cat /proc/partitions
major minor  #blocks  name

   1     0      16384 ram0
   1     1      16384 ram1
   1     2      16384 ram2
   1     3      16384 ram3
   1     4      16384 ram4
   1     5      16384 ram5
   1     6      16384 ram6
   1     7      16384 ram7
   1     8      16384 ram8
   1     9      16384 ram9
   1    10      16384 ram10
   1    11      16384 ram11
   1    12      16384 ram12
   1    13      16384 ram13
   1    14      16384 ram14
   1    15      16384 ram15
   8     0   35566479 sda
   8     1   35551813 sda1
   8    16   35843685 sdb
   8    17     200781 sdb1
   8    18   35640202 sdb2
   8    32    8027974 sdc
   8    33    8027943 sdc1
 253     0   33554432 dm-0
 253     1    2031616 dm-1
Comment 8 Tom "spot" Callaway 2008-05-17 17:09:39 EDT
OK, so the questions I have are:

1. What is sdc ?
2. What do you get when you run:
  /lib/udev/vol_id /dev/sda1
  /lib/udev/vol_id /dev/sdc1

Comment 9 Landon Kelsey 2008-05-17 17:18:18 EDT
sdc1 has always been the drive designation for the USB 2.0 port/card where a
flash memory stick has always been installed

sda1 is MS XP Prof where the ntfs has always accessed XP Prof files

LMKIII (root) ~ [944]>/lib/udev/vol_id /dev/sda1
LMKIII (root) ~ [945]>  /lib/udev/vol_id /dev/sdc1
LMKIII (root) ~ [946]>

Comment 10 Landon Kelsey 2008-05-17 17:23:26 EDT
I'll bet that the update program that changed /etc/fstab is in error


if I put back the fstab line for ntfs, ntfs will work!

It will take a while to remember it!
Comment 11 Tom "spot" Callaway 2008-05-17 17:29:49 EDT
So, your fstab says that the ntfs partition is "UUID=192C-010B", but that's
obviously wrong. It should be "UUID=DC70F0AD70F0900E". I'm not sure how you got
into that state, but fixing the fstab will resolve it.
Comment 12 Landon Kelsey 2008-05-17 17:44:55 EDT
ntfs is FIXED!

Now what do I do to fix sdc1!!! so I can look at the flash memory drive?

Several versions ago I had to put an entry in the fstab but in later Fedoras,
this became unnecessary

I can now access my bill gates files!

here is the new fstab:

UUID=25db1025-dbf4-4027-8bd7-56ef961f37ca /                       ext3   
defaults        1 1
UUID=d9713920-6459-4b98-8d9b-05cc13add8d1 /boot                   ext3   
defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/sda1          /media/Windows          ntfs    ro,umask=0222   0 0
UUID=738c5fb3-16be-44cf-97f5-4ed3427de438 swap                    swap   
defaults        0 0
Comment 13 Tom "spot" Callaway 2008-05-17 17:56:49 EDT
Well, keep in mind the following:

You're not mounting the ntfs partition by UUID, but rather, by explicit
partition name. Partition ordering is not guaranteed to be consistent, so you
might update to a new kernel and discover that /dev/sda1 isn't your NTFS
partition. I highly encourage you to replace /dev/sda1 with UUID=DC70F0AD70F0900E.

As to your USB drive, type mount, it may already be mounted (USB devices should
Comment 14 Landon Kelsey 2008-05-17 17:57:13 EDT
Created attachment 305822 [details]
snapshot showing ntfs and sdc1

here is a Konqueror snapshot showing sdc1 (flash memory drive)


the ntfs to show bill gates files
Comment 15 Tom "spot" Callaway 2008-05-17 18:04:36 EDT
Umm, okay. It looks like both devices exist. Are there any remaining problems?
Comment 16 Landon Kelsey 2008-05-17 18:20:46 EDT
just made your recommended change to



several other problems with F9

All the screensavers (like sonar and molecule) disappeared and now there is a
very limited set. 

Also the super backgrounds (from KDE) have disappeared!

I did a yumex and I have everything!

BTW how do you tell what version of kde you have?

I did a rpm -qa|grep kde but got all sorts of numbers!

I started with switchdesk kde2 and I guess that gets the latest!
Comment 17 Tom "spot" Callaway 2008-05-17 18:31:00 EDT
I'm not a KDE user, so I really can't help you with those issues. Your best bet
would be to try asking either on the Fedora Forums
(http://forums.fedoraforum.org/) or the Fedora users mailing list

Good luck!
Comment 18 Landon Kelsey 2008-05-17 19:03:07 EDT
sorry to do cross bug reports but somebody deleted my bug saying it was not
Fedora's problem since the file was a binary file! I just refiled the bug!

Changes you recommended work! Now I can see flash drive and bill gates files!

Description of problem:

boot message :

"module nvidia.ko not found for kernel

until nvidia.ko is found, the nvidia driver will not be activated"

This same problem happened several months ago and the problem was fixed!

This has to do with the order of loading/access not internal driver problems!

The problem occurred as a result of the update F8->f9

Comment 19 Tom "spot" Callaway 2008-05-17 20:10:32 EDT
The NVIDIA binary driver doesn't work with Fedora 9, this is a known issue, and
only NVIDIA can fix it (which is almost certainly why your other bug was closed).

Please don't overload this bug report, as your ntfs related issue is resolved.

Note You need to log in before you can comment on or make changes to this bug.