Bug 447088 - Syntax highlighting doesn't enable on new files automatically
Syntax highlighting doesn't enable on new files automatically
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 15:33 EDT by Harry Bock
Modified: 2008-07-16 14:44 EDT (History)
0 users

See Also:
Fixed In Version: anjuta-2.4.1-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 14:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Bock 2008-05-17 15:33:11 EDT
Description of problem:
When creating a new file and saving it with your programming language extension
of choice, syntax highlighted is not initially enabled, even when "Disable
syntax highlighting" is unchecked in Preferences. This only occurs with the
Scintilla editor; GtkSourceView is not affected. If you check and uncheck that
setting, it works as expected from that point on. Opening existing files also
works as expected.

Version-Release number of selected component (if applicable):
2.2.3-7.fc9

Steps to Reproduce:
1. Enable the Scintilla editor.
2. Ensure "disable syntax highlighting is NOT checked in Preferences
3. Create a new file in Anjuta.
4. Save as "whatever.c"
5. Start coding.
  
Actual results:
No syntax highlighting

Expected results:
Syntax highlighting

Additional info:
Works for any language, but only in the Scintilla editor.  It might be better
for that checkbox to be "Enable Syntax Highlighting" and be checked by default,
that makes more sense to me.
Comment 1 Debarshi Ray 2008-05-24 12:08:03 EDT
I am unable to reproduce it on Fedora 8 x86_64. Upstream says that he can not
reproduce it with the SVN snapshot.
Comment 2 Debarshi Ray 2008-05-25 14:51:43 EDT
Could not reproduce with Anjuta 2.4.1 on x86_64 either.
Comment 3 Harry Bock 2008-05-28 23:58:30 EDT
Running anjuta-2.4.1-1.fc9 from updates-testing, this issue is FIXED! :) Thanks
for the update, 2.4.1 seems much faster too!

Note You need to log in before you can comment on or make changes to this bug.