Bug 447114 - 'switchdesk kde' doesn't, WAS: 2 places to alter background and screensaver
'switchdesk kde' doesn't, WAS: 2 places to alter background and screensaver
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 19:42 EDT by Landon Kelsey
Modified: 2008-05-19 13:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 06:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of alternate screensaver and background (250.64 KB, image/jpeg)
2008-05-17 19:42 EDT, Landon Kelsey
no flags Details
snapshot of whole screen showing development drop down (244.92 KB, image/jpeg)
2008-05-18 12:59 EDT, Landon Kelsey
no flags Details
in Gnome(?) a background config dialog (87.40 KB, image/jpeg)
2008-05-18 14:27 EDT, Landon Kelsey
no flags Details

  None (edit)
Description Landon Kelsey 2008-05-17 19:42:53 EDT
Description of problem:

As of Fedora 9,  2 places to alter background and screensaver!

Applications: other: background and screensaver

Both of these make no difference in background or screensaver


Version-Release number of selected component (if applicable):


How reproducible:switchdesk kde2


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Landon Kelsey 2008-05-17 19:42:53 EDT
Created attachment 305826 [details]
snapshot of alternate screensaver and background
Comment 2 Kevin Kofler 2008-05-17 22:38:09 EDT
This is a screenshot of GNOME, of course GNOME has different options than KDE!
Comment 3 Landon Kelsey 2008-05-17 22:47:46 EDT
definitely NOT Gnome! Why don't you get a copy of F9 and read what I wrote!

I am through with this!

GOODNIGHT!
Comment 4 Kevin Kofler 2008-05-17 22:57:10 EDT
This is definitely GNOME, do you think I'm blind? I _know_ what the software I 
package looks like! This screenshot shows:
* panel on top, the default in GNOME
* a 2-piece menu, the default in GNOME, and I don't think you can set up Plasma 
that way
* a panel look which doesn't look like the Plasma theme in KDE 4.0, and as 
Plasma can't be themed at all in KDE 4.0, this is a definite proof that what 
you're showing there is not Plasma
* a Nodoka-themed panel menu. See previous point about theming.
* quicklaunch buttons (lots thereof) in the panel, which is a feature not 
proposed in KDE 4.0 at all (scheduled to come back in 4.1), unless you compiled 
a plasmoid from kde-look.org
* Nodoka window decorations, not Oxygen or anything else which is actually 
available in KDE 4
It can't be any more obvious that this is a screenshot of GNOME.
Comment 5 Landon Kelsey 2008-05-17 23:06:37 EDT
I moved the panel to the top!

I also ran switchdesk kde2 long ago!

You don't know what you are talking about!

gnome id decidedly different

GOODNIGHT!

are you in the USA?
Comment 6 Kevin Kofler 2008-05-17 23:20:54 EDT
"switchdesk kde2" won't work, try "switchdesk kde" or run the switchdesk GUI. 
Fedora 9 has KDE 4, not KDE 2, and the "kde" option is not versioned 
(so "switchdesk kde4" won't work either).

You are the one who doesn't know what you are talking about, and your arrogance 
towards the very maintainers you want to help you is unacceptable.
Comment 7 Landon Kelsey 2008-05-17 23:39:26 EDT
It is your arrogance and lack of experience that shows how useless bugzilla is!

I had sworn off bugzilla some years ago and now I am 100% through with it!

Too bad for Fedora!

Delete my account!
Comment 8 Landon Kelsey 2008-05-17 23:40:54 EDT
what country are you in?
Comment 9 Landon Kelsey 2008-05-17 23:43:04 EDT
here is some help for you :

LMKIII (root) ~ [982]>switchdesk kde2
Red Hat Linux switchdesk 4.0
Copyright (C) 1999-2004 Red Hat, Inc
Redistributable under the terms of the GNU General Public License
Desktop now set up to run KDE.
LMKIII (root) ~ [983]>

The first thing I do when installing a new version of Fedora is to switch to KDE.

Kepp replying and I will really get going!
Comment 10 Kevin Kofler 2008-05-18 00:38:53 EDT
YOU speak of arrogance?
The fact that switchdesk says "Desktop now set up to run KDE." sounds like a 
bug in switchdesk (Than?), but the screenshot you're showing is DEFINITELY NOT 
KDE.
Arrogance is when a stupid user thinks he knows more than the developers of the 
very software he doesn't even know how it looks like.
Oh and KDE is expected to look DIFFERENT in Fedora 8 (KDE 3) and 9 (KDE 4), if 
your desktop looks the same or almost the same, you must have been using GNOME 
all along.

Screenshots of KDE 3 in Fedora 8:
http://www.electrictoolbox.com/fedora-8-kde-screenshots/
Screenshot of KDE 4 in Fedora 9:
http://video.linux-noob.com/screenshots/fedora/9/post-67-1210463844.png
Screenshot of GNOME in Fedora 9:
http://fedoraproject.org/wiki/Tours/Fedora9/020_Fedora_Update_System
Your screenshot:
https://bugzilla.redhat.com/attachment.cgi?id=305826

As for what country I am in, this is completely irrelevant.
Comment 11 Peter Fernandes 2008-05-18 00:44:09 EDT
Landon, please refile this as a GNOME bug.  I agree that this is not a problem
with KDE.
Comment 12 Landon Kelsey 2008-05-18 00:45:26 EDT
look, get fedora 9 and work with it for a while



one more email and you'll find out what I really think

goodnight!
Comment 13 Conrad Meyer 2008-05-18 00:46:54 EDT
Looks like GNOME to me. Landon: Try [menu] -> "System" -> "About GNOME".
Comment 14 Shawn Starr 2008-05-18 01:06:47 EDT
I note that the menu in that screenshot is from GNOME, not KDE 4's Kickoff menu.
Comment 15 Rex Dieter 2008-05-18 10:12:52 EDT
Landon, I'm afraid folks here are right, switchdesk lied to you (which is a bug
in itself), your screenshots are most definitely still gnome.

Reassigning to switchdesk, hopefully than can determine how/why it failed in
this case.
Comment 16 Landon Kelsey 2008-05-18 12:10:08 EDT
all the menus are populated with KDE items

I found numerous times years ago that Gnome was impossible to work with.

It had for example no logout icon and I had forgotten (having worked in
Microsoft since my X11 days) how to enter a logout command line command.

I had to do a reboot under Gnome to get the switchdesk kde2 to work!

rebbot works on the command line
Comment 17 Landon Kelsey 2008-05-18 12:59:57 EDT
Created attachment 305864 [details]
snapshot of whole screen showing development drop down

other drop downs show a preponderance of "K" items
Comment 18 Landon Kelsey 2008-05-18 13:04:33 EDT
I just checked and there is under system "about gnome"

so I guess Gnome got busy and populated their desktop with a lot of KDE stuff

in previous versions, Gnome was extremely sparse!

I wonder when this happened!

Now: how does one properly switch to KDE!

Even under Gnome there are still multiple paths to set up background and
screensaver!

Comment 19 Landon Kelsey 2008-05-18 14:27:40 EDT
Created attachment 305868 [details]
in Gnome(?) a background config dialog

a KDE config dialog snapshot found in Gnome(?)
Comment 20 Rex Dieter 2008-05-18 14:37:24 EDT
It's perfectly legal to find kde apps in gnome, and vice-versa.  The only
exceptions are items that are (or should be) gnome or kde only, and such items
should appear only on their respective desktops.

As per that last item you found, it should be fixed in:
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-4089
Comment 21 Landon Kelsey 2008-05-18 16:13:59 EDT
great! thanks!  

now how does one switch to KDE if switchdesk doesn't do it?

I can understand 

"It's perfectly legal to find kde apps in gnome, and vice-versa"

but my beloved background config dialog from KDE (I've used for years has NO
effect on anything!

This must be one of the things that shouldn't show up in Gnome.

ALSO-> I updated F8 that was running KDE with all my favorites working great!

The update F8->F9 also ruined my fstab entry for ntfs but I fixed that (another
bug in here)

In past Fedora 8,7,6,5 I used it to set my background.

I had predicted that an update F8->F9 would be a disaster (as in the past) and
all this must be the result of it!
Comment 22 Rex Dieter 2008-05-18 16:18:25 EDT
> now how does one switch to KDE if switchdesk doesn't do it?

At login screen, choose "kde" session instead of "gnome".

And, please keep in mind: *one* issue per bug please.  (and to be clear,
bugzilla is not really a good support forum for questions, stuff like that is
much better suited to mailing lists (fedora-general?) or fedoraforum.org).
Comment 23 Rex Dieter 2008-05-18 16:21:42 EDT
or heck, even irc, #fedora on freenode.  See also:
http://fedoraproject.org/wiki/Communicate
Comment 24 Landon Kelsey 2008-05-18 16:41:57 EDT
(1) I reported a true problem in Fedora, I didn't ask for help! Not my fault
that switchdesk stopped working!

(2) I've logged in 1000000 times and I've NEVER EVER seen any facility to select
KDE or Gnome at login. To make sure I just logged out and then back in!

What planet did I land on?

With all due respect, I am through with bugzilla.

I had sworn bugzilla off some time ago when people were not able to perceive the
obvious problem in spite of screen snapshots! I think there is resistance to
recognizing bugs! 

This is a time when Fedora should be more and more palatable to new users to
fight Microsoft!

I love Linux but this is absurd!

Again: goodbye! That should make you happy!
Comment 25 Rex Dieter 2008-05-18 17:35:42 EDT
We've all been trying to be helpful, address your issues, correct your
misconceptions, and point you in the right direction on when/where to get the
best help available.

If that's not good enough, by all means, close this bug and wash your hands of it.
Comment 26 Ngo Than 2008-05-19 06:38:09 EDT
I'm surely that you are using GDM as X login manager and the default session
type is gnome. If the session type is set to Gnome, the gnome desktop will be
started independent of what you changed with switchdesk. It's correct behavor,
because this session type was choosed explicit.

If the session type is set to default, The GDM/KDM X login managers will start
the session type what you change with switschdesk.

In your case if you use GDM, you have to select explicit the session type KDE,
because GDM doesn't provide default session (it's bug in GDM). Or you can switch
to KDM which provides default session.

To switch to KDM just add following line in /etc/sysconfig/desktop

DESKTOPMANAGER=KDE

then do telinit 3 and telinit 5.
Comment 27 Kevin Kofler 2008-05-19 06:41:24 EDT
That would be:
DISPLAYMANAGER="KDE"
(not DESKTOPMANAGER).
Comment 28 Kevin Kofler 2008-05-19 06:47:06 EDT
Oh, and shouldn't there be a bug filed against GDM for this? IMHO it should use 
the Default session as the default, users expect switchdesk to actually work, 
and it did in the past.
Comment 29 Landon Kelsey 2008-05-19 11:04:19 EDT
switching desktop is supposed work as it has in the past

switching desktops should be simple as it has been in the past

why WHY is there such denial in these ranks!

we should be working to make Linux more palatable to the users NOT more complex
Comment 30 Landon Kelsey 2008-05-19 12:59:17 EDT
than there is no directory as you said:

you should check what you post

LMKIII (root) /etc/sysconfig [1005]>lsa /etc/sysconfig/desktop
ls: cannot access /etc/sysconfig/desktop: No such file or directory
LMKIII (root) /etc/sysconfig [1006]>
Comment 31 Kevin Kofler 2008-05-19 13:07:21 EDT
That file is not there by default, you have to create it.
Comment 32 Landon Kelsey 2008-05-19 13:17:00 EDT
BTW I have not been using Gnome all this time as you stated in your attempt to
humiliate me!

After installing F8 and previous versions, I'd try Gnome and give up switching
to KDE. In F8 and before the difference was pronounced!

For example there was no logout facility or monitor window facility!

I forget who it was above that said that it must be Gnome because the panel is
at the top! There were some other great comments!

Comment 33 Landon Kelsey 2008-05-19 13:40:10 EDT
thanks! that worked! Now I have all my old KDE stuff!

also thanks to whoever made the comment about choosing the desktop(KDE or Gnome)
at login!

all desktops allow the panel at the top!

what a nightmare!

I still love Fedora  but not ___!

The problems in Gnome are unmistakeable but leave them!


Note You need to log in before you can comment on or make changes to this bug.