Bug 447118 - Rhythmbox no longer automatically lists DAAP shares
Rhythmbox no longer automatically lists DAAP shares
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 19:56 EDT by W. Michael Petullo
Modified: 2008-05-19 16:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 16:03:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2008-05-17 19:56:33 EDT
Description of problem:
I use rhythmbox as my audio player and mt-daapd as my media server. Rhythmbox used to list my mt-
daapd DAAP share automatically because mt-daapd publishes its share using Avahi. Rhythmbox now 
does not list the share until I manually select Music -> Connect to DAAP Share. 

Version-Release number of selected component (if applicable):
rhythmbox-0.11.5-9.fc9.ppc

How reproducible:
Every time

Steps to Reproduce:
1. Install and configure mt-daapd
2. Start rhythmbox
  
Actual results:
Rhythmbox does not list mt-daapd's DAAP share.

Expected results:
Rhythmbox should list mt-daapd's DAAP share without the user manually connecting to it. This is how 
things worked out of the box when using F-8.

Additional info:
iTunes detects my mt-daapd DAAP share automatically as I would expect.

I tried to downgrade to a previous version of rhythmbox from F-8, but that did not fix the problem.
Comment 1 Bastien Nocera 2008-05-19 06:23:33 EDT
Could you please try disabling the firewalls on both machines, and restarting
Avahi (and Rhythmbox/mt-daapd as well).
Comment 2 W. Michael Petullo 2008-05-19 16:03:58 EDT
Yes, you got it.

Sorry, I had turned off the firewall on the mt-daapd server, but not my Rhythmbox client. I guess I didn't 
put much thought into how mDNS/DNS-SD works.

For the record, adding the following line to my client's /etc/sysconfig/iptables allows avahi through the 
client's firewall:

-A INPUT -m state --state NEW -m udp -p udp --dport 5353 -j ACCEPT
Comment 3 Bastien Nocera 2008-05-19 16:28:33 EDT
See bug 444427

Note You need to log in before you can comment on or make changes to this bug.