Bug 447126 - /etc/pam.d/system-auth should be listed as a symlink in pam spec file
/etc/pam.d/system-auth should be listed as a symlink in pam spec file
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 22:29 EDT by petrosyan
Modified: 2008-05-18 15:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-18 15:27:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2008-05-17 22:29:37 EDT
Description of problem:
/etc/pam.d/system-auth is a symlink to system-auth-ac however pam's spec file
lists it as a regular file.
/etc/pam.d/system-auth 683 1208976369 b0c0297178ababca749614b034f85c16 0100644
root root 1 0 0 X

This causes verification error for pam package.

Version-Release number of selected component (if applicable):
pam-1.0.1-2.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. rpm -V pam
2. ls -l /etc/pam.d/system-auth
3. rpm -q --dump pam | grep pam.d/system-auth
Comment 1 Tomas Mraz 2008-05-18 15:27:31 EDT
The system-auth must be regular file in the pam package because the authconfig
which does the symlinking doesn't have to be installed on system. Authconfig
also recognizes whether the configuration is already changed by it by looking at
the system-auth file - if it is regular file -> it can change it to symlink
pointing it to system-auth-ac; if it is a symlink it will leave it alone.
Administrator can change then the symlink to point to a different file which can
contain local PAM config adjustments.

Note You need to log in before you can comment on or make changes to this bug.