Bug 447139 - TurboGears version conflict with python-cherrypy
TurboGears version conflict with python-cherrypy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: TurboGears (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 04:13 EDT by Pieter Krul
Modified: 2016-09-19 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 10:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New patch for src.rpm (702 bytes, patch)
2008-05-18 04:13 EDT, Pieter Krul
no flags Details | Diff
Patch to src.rpm (701 bytes, patch)
2008-05-18 04:16 EDT, Pieter Krul
no flags Details | Diff

  None (edit)
Description Pieter Krul 2008-05-18 04:13:02 EDT
Description of problem:
Fedora 9 comes with python-cherrypy-3.0.3-2.f9. When you install TurboGears, and
when you try to use it, an error is thrown:

  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 528, in resolve
    raise VersionConflict(dist,req) # XXX put more info here

When viewing requirements in 
/usr/lib/python2.5/site-packages/TurboGears-1.0.4.4-py2.5.egg-info/requires.txt,
the following is displayed at the top line:
CherryPy >= 2.3.0,<3.0.0alpha

This should read at least CherryPy >= 2.3.0,<=3.0.3, since this version is
actually installed with Fedora 9

Patch #1 from the .src.rpm of TurboGears (TurboGears-1.0.4.4-cherrypyreq.patch),
 is incomplete

Version-Release number of selected component (if applicable):
1.0.4.4-2.fc9

How reproducible:
Always

Steps to Reproduce:
1. yum -y install TurboGears
2. Run python
pkrul@kdc:~ :) > python
Python 2.5.1 (r251:54863, Apr  8 2008, 01:20:16) 
[GCC 4.3.0 20080404 (Red Hat 4.3.0-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pkg_resources
>>> pkg_resources.require("TurboGears")

  
Actual results:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 626, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 528, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (CherryPy 3.0.3
(/usr/lib/python2.5/site-packages),
Requirement.parse('CherryPy>=2.3.0,<3.0.0alpha'))

Expected results:

[TurboGears 1.0.4.4 (/usr/lib/python2.5/site-packages), TurboKid 1.0.4
(/usr/lib/python2.5/site-packages), TurboJson 1.1.2
(/usr/lib/python2.5/site-packages), TurboCheetah 1.0
(/usr/lib/python2.5/site-packages), simplejson 1.8.1
(/usr/lib/python2.5/site-packages), setuptools 0.6c7
(/usr/lib/python2.5/site-packages), RuleDispatch 0.5a0.dev-r2306
(/usr/lib/python2.5/site-packages), PasteScript 1.6.2
(/usr/lib/python2.5/site-packages), FormEncode 1.0
(/usr/lib/python2.5/site-packages), DecoratorTools 1.7
(/usr/lib/python2.5/site-packages), configobj 4.5.2
(/usr/lib/python2.5/site-packages), CherryPy 3.0.3
(/usr/lib/python2.5/site-packages), kid 0.9.6
(/usr/lib/python2.5/site-packages), RuleDispatch 0.5a0.dev-r2306
(/usr/lib/python2.5/site-packages), Cheetah 2.0.1
(/usr/lib/python2.5/site-packages), PyProtocols 1.0a0dev-r2302
(/usr/lib/python2.5/site-packages), PasteDeploy 1.3.1
(/usr/lib/python2.5/site-packages), Paste 1.6
(/usr/lib/python2.5/site-packages), DecoratorTools 1.7
(/usr/lib/python2.5/site-packages)]

Additional info:

Patch attached. This is required for Freeipa ipa_webgui to run properly
Comment 1 Pieter Krul 2008-05-18 04:13:02 EDT
Created attachment 305836 [details]
New patch for src.rpm
Comment 2 Pieter Krul 2008-05-18 04:16:51 EDT
Created attachment 305837 [details]
Patch to src.rpm
Comment 3 Toshio Ernie Kuratomi 2008-05-19 10:16:44 EDT
TurboGears-1.0.x is not supposed to work with CherryPy-3.x.

The requirements in the TurboGears rpm properly specify the python-cherrypy2
package.

There should have been a note in the release notes explaining that newly created
web applications should be fine but old ones would need to have some changes
made but it looks like we didn't get the correct notes listed :-(  In Fedora 9,
the changes noted here should be necessary for any system with both
python-cherrypy and python-cherrypy2 installed, not just sqlalchemy:
http://docs.fedoraproject.org/release-notes/f9/en_US/sn-WebServers.html#sn-turbogears-apps

If you make those changes and freeipa's webgui doesn't work, I'll be happy to
help you port it.  Just let me know what cvs module I need to checkout and what
command I need to run.
Comment 4 Toshio Ernie Kuratomi 2008-05-19 10:36:29 EDT
Request to update the release notes has been added::
  http://fedoraproject.org/wiki/Docs/Beats/WebServers

Note You need to log in before you can comment on or make changes to this bug.