Bug 447160 - ACPI Errors - unable to bring up video after suspend
Summary: ACPI Errors - unable to bring up video after suspend
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-18 11:33 UTC by Jonathan Dawson
Modified: 2009-07-14 15:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 15:46:57 UTC


Attachments (Terms of Use)
dmesg file from pm-suspend (26.04 KB, application/octet-stream)
2008-05-18 11:33 UTC, Jonathan Dawson
no flags Details

Description Jonathan Dawson 2008-05-18 11:33:36 UTC
Description of problem:
Sleeping function called from invalid context bug and ACPI errors logged -
unable to bring video up on Sony Vaio PCG-FX801 after pm-suspend from a
terminal. The system does still respond, though. Have tried all the obvious
quirks and still no video.

Version-Release number of selected component (if applicable):
Applicable to released versions of hal, hal-info, hal-libs with Fedora 9 and
with latest versions, i.e. hal-info-0.5.11-1.fc9.noarch, hal-0.5.11-1.fc9.i386
hal-libs-0.5.11-1.fc9.i386. 

How reproducible:
Every time.

Steps to Reproduce:
1. Boot system
2. Log in either via terminal window or kde.
3. From shell type pm-suspend
  
Actual results:
System suspends to ram. Hitting key or power button to resume results in disk
activity but no video

Expected results:
As above but with video working

Additional info:
have tried dpms-on, vbemode-restore, vbestate-restore, vga-mode3 in all
combinations but still doesn't work

Comment 1 Jonathan Dawson 2008-05-18 11:33:36 UTC
Created attachment 305842 [details]
dmesg file from pm-suspend

Comment 2 Bug Zapper 2009-06-10 00:57:55 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Bug Zapper 2009-07-14 15:46:57 UTC
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.