Bug 447162 - All the packages displayed in Other
All the packages displayed in Other
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 08:15 EDT by Jan Kratochvil
Modified: 2008-05-30 22:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.1.12-13.20080522.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 22:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-05-18 08:15:05 EDT
Description of problem:
When I run `gpk-application' only the category `Other' contains all of the
installed+available packages. Other categories (such as `Office') are empty.

Version-Release number of selected component (if applicable):
PackageKit-0.1.12-10.20080505.fc9.x86_64
yum-3.2.14-10.fc9.noarch
gnome-packagekit-0.1.12-12.20080430.fc9.x86_64
(updated Fedora 9, system is being upgraded since Fedora Core 1 or so.)

How reproducible:
Always.

Steps to Reproduce:
1. Run `Add/Remove Software'.
2. Click `Office'.
3. Wait.
4. Wait.

Actual results:
No results were found

Expected results:
Packages like OpenOffice.org.

Additional info:
It was fixed by doing:
yum install yum-list-data
yum list-groups
# which downloaded:
comps-f9.xml                                             | 1.3 MB     00:32     
comps.xml                                                |  12 kB     00:00    
Fedora-9-comps.xml.gz                                    | 311 kB     00:08     
Fedora-9-comps.xml.gz                                    | 311 kB     00:22     
comps-f9.xml                                             | 1.3 MB     00:32     

and since that moment `gpk-application' now displays the groups correctly.
But sure this comps download should have happened automatically.
Comment 1 Fedora Update System 2008-05-22 16:41:01 EDT
PackageKit-0.1.12-13.20080522.fc9 has been submitted as an update for Fedora 9
Comment 2 Richard Hughes 2008-05-28 05:27:24 EDT
Is this still a problem?
Comment 3 Jan Kratochvil 2008-05-28 07:03:19 EDT
It now reports:
  The group was not found
  comps categories could not be loaded

I am sure my grandfather running Fedora will not be able to fix it himself.
I expected he will be able to install there some Games from Fedora Everything.
In fact I spent some time to find `yum list-groups' myself for this Comment 0
and well I am running Red Hat since its version 4.x.

PackageKit is there IMO to make the package management user friendly.  I still
rather use rpm (or unfortunately yum) myself as I find the commandline more
convenient.  But I would like to make Fedora accessible for the end-users.

Sure thanks for the update but I still do not find this Bug to be solved.
Comment 4 Richard Hughes 2008-05-28 09:07:59 EDT
>Sure thanks for the update but I still do not find this Bug to be solved.

Right, but now we know what the problem is.

cats = self.yumbase.comps.categories
if len(cats) == 0:
    self.error(ERROR_GROUP_LIST_INVALID,'comps categories could not be loaded')

Robin, would it be possible to refresh the comps list at this stage?
Comment 5 Fedora Update System 2008-05-28 22:52:41 EDT
PackageKit-0.1.12-13.20080522.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4646
Comment 6 Fedora Update System 2008-05-30 22:17:35 EDT
PackageKit-0.1.12-13.20080522.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.