This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 447174 - Missing instructions for set up an installation server without cobbler
Missing instructions for set up an installation server without cobbler
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: Paul W. Frields
Paul W. Frields
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 10:56 EDT by Edgar Hoch
Modified: 2008-07-25 20:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 20:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edgar Hoch 2008-05-18 10:56:15 EDT
Description of problem:
In Fedora 9 installation guide Part "C. Setting Up an Installation Server"
there is only a description how to set up an installation server using clobber.
The instructions how to create an installtion server without clobber are missing.

But there are reasons not to use clobber.
We want to have the dhcp server, the server providing the installation image and
the server providing the kickstart configuration file on different hosts, and
not all of these servers may run fedora.
Also we want to control where the data (installation image, configuration, etc)
are copied, because the default partitions may not have enough free space.
One more reason is that we man want to use scripts.

So it would be very good to have instructions how to do it manual.
We should know the content and directory structure of the installation image
that anaconda can use.
We should know what dhcp informations the dhcp server should provide.
We should know what the tftp server should provide.
We should know how to create the kickstart directory.

As I use fedora since years with kickstart and network installation, I will try
do do it in the same way as for previous versions. But this is not appropriate
to new users. Also I don't know it the old methode is still applicaple to F9.

It would be nice if the missing part will be re-integrated in the installation
guide in an updates online version (and of course, in following versions of Fedora).

Thanks in advance!
Comment 1 Paul W. Frields 2008-07-25 20:18:46 EDT
Unfortunately, the amount of information needed to convey all these steps far
exceeds the scope of the Installation Guide.  Unfortunately, we can't cover
every single use case in the IG because of the limited volunteer resources we
have for writing it.  However, you might want to consider participating in
making a document on the Fedora Project wiki for this scenario.  Closing as
WONTFIX -- not because this isn't a good idea, but simply because the IG can't
handle it well.

Note You need to log in before you can comment on or make changes to this bug.