Bug 447187 - no fedora-9-*.cfgs
no fedora-9-*.cfgs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
8
All Linux
high Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 13:02 EDT by Ralf Corsepius
Modified: 2013-01-09 20:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 22:35:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-05-18 13:02:26 EDT
Description of problem:
mock on FC8 lacks /etc/mock/fedora-9-*.cfg's

Please add them.


Version-Release number of selected component (if applicable):
mock-0.9.7-2.fc8
Comment 1 Jesse Keating 2008-05-18 15:06:42 EDT
mock-0.9.9-1.fc8 which is in updates-testing has the configs.  However there is
a small problem with this build in that the exclude= line for x86_64 repos was
accidentally removed.  A newer build will be coming later to fix /that/ issue,
but it does have the f9 configs.
Comment 2 Ralf Corsepius 2008-05-20 06:13:18 EDT
@f13: I am not sure you understand the seriousness of this bug. Unless this
issue is fixed, it's not possible to use FC8 as development platform for Fedora,
because FC9 is missing.

BTW: Wouldn't be to syncing FC8's mock (and yum) with FC9's be an option?

Comment 3 Jesse Keating 2008-05-20 07:19:38 EDT
Perhaps you can pull the update from updates-testing and tell us how that works
for you.
Comment 4 Ralf Corsepius 2008-05-20 07:50:46 EDT
How about YOU testing the SW in advance before the release, Mr. Keating?
Comment 5 Jesse Keating 2008-05-20 09:33:48 EDT
I ran it through our release testing suite.  However I can't possibly test it in
each and every scenario that our userbase uses mock in.  That is why we have
updates-testing to allow for a wider audience to take part in testing the
software.  I'm sorry you don't understand that.
Comment 6 Ralf Corsepius 2008-05-20 09:53:02 EDT
(In reply to comment #5)
> I ran it through our release testing suite.  However I can't possibly test it in
> each and every scenario that our userbase uses mock in.  That is why we have
> updates-testing to allow for a wider audience to take part in testing the
> software.
The "wider audience", I am part of has developed a local hack to keep things
going, like the "wider audience" did in the "dark RHL" ages, because RH has not
been able to provide a proper upgrade/update in time.

>  I'm sorry you don't understand that.
My point it: It's been a while since FC9 is out, but Mr. Keating has not been
able to provide packages to allow a smooth transition on using Fedora's CVS for
FC8 users in time.
Comment 7 Jesse Keating 2008-05-20 10:04:29 EDT
"Mr Keating" isn't the upstream of this software, nor is he the only maintainer.
 It is however extremely simple to copy the F8 config and call it F9 and modify
one or two lines of config file.  Of course we'll try to have the mock update
ready ahead of time prior to the next release, but crap happens and releases
slip and things get really busy.  Such is life.
Comment 8 Fedora Update System 2008-05-20 16:18:52 EDT
mock-0.9.10-1.fc9 has been submitted as an update for Fedora 9
Comment 9 Ralf Corsepius 2008-05-21 04:52:51 EDT
(In reply to comment #7)
> "Mr Keating" isn't the upstream of this software, nor is he the only maintainer.

OK, Mr. Keating@RH is the person who denies to take responsibility and prefers
to push around volunteers, instead - Shame on you.
Comment 10 Fedora Update System 2008-05-21 06:57:27 EDT
mock-0.9.10-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4189
Comment 11 Fedora Update System 2008-10-20 15:46:05 EDT
mock-0.9.12-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/mock-0.9.12-1.fc9
Comment 12 Fedora Update System 2008-10-23 12:39:56 EDT
mock-0.9.12-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9074
Comment 13 Fedora Update System 2008-11-06 17:34:40 EST
mock-0.9.13-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/mock-0.9.13-1.fc9
Comment 14 Fedora Update System 2008-11-06 17:34:50 EST
mock-0.9.13-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/mock-0.9.13-1.fc8
Comment 15 Fedora Update System 2008-11-07 21:10:49 EST
mock-0.9.13-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9499
Comment 16 Fedora Update System 2008-11-07 21:11:49 EST
mock-0.9.13-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-9512
Comment 17 Fedora Update System 2008-11-12 22:35:36 EST
mock-0.9.13-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2008-11-12 22:37:26 EST
mock-0.9.13-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.