Bug 447211 - RFE: system-config-network should support non-numeric alias like "eth0:DNS"
RFE: system-config-network should support non-numeric alias like "eth0:DNS"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 16:31 EDT by David Tonhofer
Modified: 2013-12-13 05:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 05:43:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2008-05-18 16:31:01 EDT
Description of problem:

Create an aliased eth0:DNS in "/etc/sysconfig/networking/devices"

(Why use "DNS" instead of "01"? Because:

   - It works in RH ES 4
   - Using short strings indicating what the alias is for is better 
     than carrying an Excel table along )

Starting system-config-network gives the error dialog:

"eth0:DNS, Device not specified or alias not a number!"

It then shows the devices but evidently there are problems with activation.

Version-Release number of selected component (if applicable):

system-config-network-1.5.5-1.fc8

How reproducible:

Always

Trial data:

In "/etc/sysconfig/networking/devices" create file ifcfg-eth0:

DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.168.1.255
HWADDR=00:02:B3:33:35:D2
IPADDR=192.168.1.1
NETMASK=255.255.255.0
NETWORK=192.168.1.0
ONBOOT=yes
GATEWAY=192.168.1.254
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=no
NM_CONTROLLED=no

Additionally create file ifcfg-eth0:DNS

DEVICE=eth0:DNS
BOOTPROTO=none
BROADCAST=192.168.1.255
IPADDR=192.168.1.3
NETMASK=255.255.255.0
NETWORK=192.168.1.0
ONBOOT=yes
GATEWAY=192.168.1.254
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=no
NM_CONTROLLED=no

Expected results:

system-config-network should be able to handle "non-numeric alias".
Comment 1 Harald Hoyer 2008-05-19 04:40:01 EDT
yes it should
Comment 2 Fedora Admin XMLRPC Client 2012-12-19 10:30:38 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Nils Philippsen 2013-12-13 05:43:31 EST
We've kept/resurrected s-c-network only as a stop-gap measure until NetworkManager grows some still missing functionality. I won't add new features to it, though. Closing.

Note You need to log in before you can comment on or make changes to this bug.