Bug 447220 - links not resolved properly
links not resolved properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sysfsutils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 446947
  Show dependency treegraph
 
Reported: 2008-05-18 17:46 EDT by Zing
Modified: 2008-06-24 22:53 EDT (History)
0 users

See Also:
Fixed In Version: 2.1.0-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 22:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zing 2008-05-18 17:46:35 EDT
Description of problem:
From http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=481015
"There is a subtle but crucial flaw in the way sysfs_get_link()
resolves relative links of the pattern ../../abcd. In such a case,
sysfs_get_link() will simply discard trailing components of it's path
argument without checking whether they themselves are links and should
be resolved first."

The above causes multipathd to seg fault on startup:
https://bugzilla.redhat.com/show_bug.cgi?id=446947

I've locally patched libsysfs with the debian patch and this helps the seg fault
for multipathd (multipathd has an additionally problem although I am unsure
where the fault is).

Version-Release number of selected component (if applicable):
libsysfs-2.1.0-3.fc9.x86_64
Comment 1 Jarod Wilson 2008-05-20 10:36:48 EDT
Would love to just take sysfsutils out back and shoot it, since it appears to be
pretty much completely dead upstream since the 2.1.0 release. The debian patch
has been sent to the project mailing list, but no replies from any developers.
I've gone ahead and tacked it onto a rawhide build that is working its way
through the build system right now.
Comment 2 Zing 2008-05-20 10:51:28 EDT
thanks, fyi, it looks like multipathd upstream has ripped out libsysfs as a
dependency...  which is good thing. :)
Comment 3 Jarod Wilson 2008-05-20 11:01:51 EDT
Good to know dm-multipath has ripped that out... :)

I'm also going to push an F9 updates-testing build of this patched sysfsutils,
and probably an F8 updates-testing one as well, as F8 may rebase to a 2.6.25
kernel soon.
Comment 4 Fedora Update System 2008-05-20 11:07:28 EDT
sysfsutils-2.1.0-4.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-05-20 11:13:42 EDT
sysfsutils-2.1.0-4.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-05-21 06:56:54 EDT
sysfsutils-2.1.0-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sysfsutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4182
Comment 7 Fedora Update System 2008-06-24 22:53:39 EDT
sysfsutils-2.1.0-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-06-24 22:53:44 EDT
sysfsutils-2.1.0-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.