This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 447221 - F9 anaconda requires lspci that is not included in minstg2.img
F9 anaconda requires lspci that is not included in minstg2.img
Status: CLOSED DUPLICATE of bug 445974
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 18:15 EDT by neomjp
Modified: 2008-05-19 09:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 09:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description neomjp 2008-05-18 18:15:42 EDT
Description of problem:
During an installation on a low-memory machine according to "Installation Guide
Appendix B. Installing Without Media" (booting from vmlinuz and initrd.img only,
and then use ftp method to retrieve other files.). An error occurred, saying:

Unable to read group information from repositories. This is a problem with the
generation of your install tree.

It also give an error about lcpci in Ctrl-Alt-F3 window.

This error message is from doRepoSetup() (in /usr/lib/anaconda/yuminstall.py)
for a failure of doGroupSetup() (also in yuminstall.py). This is because
doGroupSetup() calls iutil.isVmware() (in /usr/lib/anaconda/iutil.py), and it
then calls hard-coded /usr/sbin/lspci, which is not included in minstg2.img
(loop-back mounted at /mnt/runtime).

Version-Release number of selected component (if applicable):
anaconda of the version included in released Fedora 9 

How reproducible:
Always

Steps to Reproduce:
1. Start an installation on a low-memory machine according to "Installation
Guide Appendix B. Installing Without Media" (booting from vmlinuz and initrd.img
only, and then use ftp method to retrieve other files.)
2.
3.
  
Actual results:
Installation stalls with the message above.

Expected results:
Installation continues.

Additional info:
Possible solutions are:
1. add /sbin/lspci to minstg2.img
2. change the implementation of isVmware() to not use lspci.

A brute force ugly workaround is to put some executable file with the name
"lspci". To do it, I had to create a disk image with the content of /usr/sbin,
and remount
/usr/sbin.

cd /mnt/sysimage/boot
cp -ir /usr/sbin .
dd if=/dev/zero of=sbin.img bs=512 count=16384
/usr/sbin/mkfs.ext2 sbin.img
mount -t ext2 -o loop sbin.img /usr/sbin
cp -ir sbin/* /usr/sbin
ln -s /usr/bin/busybox /usr/sbin/lspci

The executable file could be anything, so long as it does not return a string
with the word "vmware".
Comment 1 Chris Lumens 2008-05-19 09:25:05 EDT

*** This bug has been marked as a duplicate of 445974 ***

Note You need to log in before you can comment on or make changes to this bug.