Bug 447232 - Compiz returns back to old workspace by itself
Compiz returns back to old workspace by itself
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 19:24 EDT by Bojan Smojver
Modified: 2008-06-22 16:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.7.6-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-22 16:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2008-05-18 19:24:52 EDT
Description of problem:
I'm having a feeling I'm getting hit by something that may have been fixed upstream:

http://gitweb.freedesktop.org/?p=xorg/app/compiz.git;a=commit;h=67bc2cd6e4b00439d865493f4e46b1c2c608be77
http://gitweb.freedesktop.org/?p=xorg/app/compiz.git;a=commit;h=a8c7c895483f7450a9d5292372a9088f5c5a62e6

Full shortlog is here:

http://gitweb.freedesktop.org/?p=xorg/app/compiz.git;a=shortlog;h=compiz-0.7.4

Essentially, sometimes when workspace is changed by clicking to a different
workspace rectangle in workspace switcher, compiz quickly flicks to that new
workspace, but then returns back to the old one (I'm guessing due to focus being
put onto a window on that old workspace). I'm not using the "workspaces on a
cube" option, nor wobbly windows.


Version-Release number of selected component (if applicable):
0.7.2-3.fc9

How reproducible:
Sometimes.

Steps to Reproduce:
1. Do something in a window on one workspace (e.g. Evolution).
2. Use workspace switcher to change workspaces.
3. See compiz occasionally flick back to old workspace.
  
Actual results:
Returns workspace to the old one, not the one selected in workspace switcher.

Expected results:
Should not do that (i.e. it should honour user's workspace request).

Additional info:
I think this is fixed in 0.7.4, so something as simple as a rebuild may help.
See URLs from compiz git.
Comment 1 Bojan Smojver 2008-05-20 19:18:56 EDT
BTW, I'm running "Select windows when mouse moves over them" setting. You may
not observe this bug without that being set.
Comment 2 Bojan Smojver 2008-06-05 22:59:37 EDT
Ping...
Comment 3 Fedora Update System 2008-06-14 02:26:45 EDT
ccsm-0.7.6-2.fc9,compizconfig-python-0.7.6-1.fc9,compizconfig-backend-kconfig-0.7.6-1.fc9,compizconfig-backend-gconf-0.7.6-1.fc9,libcompizconfig-0.7.6-1.fc9,compiz-fusion-extras-0.7.6-1.fc9,compiz-fusion-0.7.6-1.fc9,compiz-0.7.6-2.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-16 19:33:28 EDT
ccsm-0.7.6-2.fc9, compizconfig-python-0.7.6-1.fc9, compizconfig-backend-kconfig-0.7.6-1.fc9, compiz-fusion-extras-0.7.6-1.fc9, compizconfig-backend-gconf-0.7.6-1.fc9, libcompizconfig-0.7.6-1.fc9, compiz-fusion-0.7.6-1.fc9, compiz-0.7.6-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ccsm compizconfig-python compizconfig-backend-kconfig compiz-fusion-extras compizconfig-backend-gconf libcompizconfig compiz-fusion compiz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5395
Comment 5 Fedora Update System 2008-06-22 16:44:51 EDT
ccsm-0.7.6-2.fc9, compizconfig-python-0.7.6-1.fc9, compizconfig-backend-kconfig-0.7.6-1.fc9, compiz-fusion-extras-0.7.6-1.fc9, compizconfig-backend-gconf-0.7.6-1.fc9, libcompizconfig-0.7.6-1.fc9, compiz-fusion-0.7.6-1.fc9, compiz-0.7.6-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.