Bug 447233 - NetworkManager man page references NetworkManagerDispatcher
Summary: NetworkManager man page references NetworkManagerDispatcher
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-18 23:28 UTC by Todd J Martin
Modified: 2009-03-16 17:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-16 17:16:53 UTC


Attachments (Terms of Use)

Description Todd J Martin 2008-05-18 23:28:13 UTC
Description of problem:

The man page for NetworkManager (8) references the NetworkManagerDispatcher (8)
man page, which no longer exists because NetworkManagerDispatcher has ceased to be.

Version-Release number of selected component (if applicable):

[todd@hobbes dispatcher.d]$ rpm -q NetworkManager
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386

How reproducible:


Steps to Reproduce:
1. man 8 NetworkManager
  
Actual results:

Look under SEE ALSO for NetworkManagerDispatcher (8)

Expected results:

NetworkManager (8) should not reference man pages that do not exist.  The
information that used to be in NetworkManagerDispatcher (8) is still relevant
because is describes the calling interface to scripts placed in
/etc/NetworkManager/dispatcher.d.  I do not see where any man pages currently
document that interface.  Some of the information that was in
NetworkManagerDispatcher (8) should probably be rolled into NetworkManager (8).

Additional info:

Comment 1 Dan Williams 2009-03-03 20:46:09 UTC
Big manpage rewrite done for 0.7.1

Comment 2 Dan Williams 2009-03-16 17:16:53 UTC
Already pushed out in F9, F10, and rawhide in any NM version >= 0.7.0.97.


Note You need to log in before you can comment on or make changes to this bug.