Bug 44724 - RFE: genhdlist is part of anaconda RPM...not easily accessible
Summary: RFE: genhdlist is part of anaconda RPM...not easily accessible
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-15 18:46 UTC by Joe Cooper
Modified: 2007-03-27 03:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 22:55:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Cooper 2001-06-15 18:46:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-14 i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
genhdlist, a simple console program, is now included in the anaconda
package, making it inaccessible on non-X equipped machines.  I have a
system that is used for performing remote installs, as well as creating new
versions of the CD with updates.  Because genhdlist is somewhat tied to the
version of Red Hat to be 'fiddled with' having it inside of a graphics
requiring package is a nuisance.  I had to compile genhdlist manually /on/
a Red Hat 7.1 machine and then copy it to where I needed it.  It's all
wrong.  Please put it back somewhere easily accessible on the CD, or at
least give it it's own RPM package that doesn't require 15 different
libraries to install or build.

Thanks.

How reproducible:
Always

Steps to Reproduce:
1. Look for genhdlist on the Red Hat 7.1 CD.
2. Don't find it.
3. Curse loudly, and figure out where they've stashed it.
	

Actual Results:  I tried to use an old version of genhdlist.  That failed.
Compiled a new genhdlist on a RH7.1 machine, and copied it to my NFS
install machine.  That worked.

Expected Results:  I should have been able to build a Red Hat CD with all
updates and my custom packages without having to resort to compiling parts
by hand.

Additional info:

Thank you.

Comment 1 Jeremy Katz 2001-08-03 16:14:55 UTC
anaconda-runtime package won't require anaconda in the future, hence you won't
pull in the X requirements


Note You need to log in before you can comment on or make changes to this bug.