Bug 447245 - kdm pam settings need to sync with gdm
kdm pam settings need to sync with gdm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 23:31 EDT by Christopher Stone
Modified: 2008-07-02 20:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.0-24.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 01:25:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2008-05-18 23:31:27 EDT
NetworkManager will prompt the user for a password if the user uses KDM.  This
can by fixed by using the gdm settings found in /etc/pam.d and copying them over
to /etc/pam.d/kdm
Comment 2 Rex Dieter 2008-05-20 10:33:08 EDT
* Tue May 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0-24
- kdm pam settings need to sync with gdm (#447245)

In particular, sync'd gdm
gdm -> kdm
gdm-autlogin -> kdm-np
and gnome-screensaver:
gnome-screensaver -> kscreensaver
gnome-screensaver -> kcheckpass

Please test:
http://koji.fedoraproject.org/koji/taskinfo?taskID=619998
Comment 3 Fedora Update System 2008-05-20 11:53:22 EDT
kde-settings-4.0-24.fc9 has been submitted as an update for Fedora 9
Comment 4 Christopher Stone 2008-05-24 20:44:35 EDT
I can confirm that NetworkManager does not ask for a password using these rpms.
 Also, the PackageManager icon seems to work better with PolicyKit now.  I'm not
sure how to test the screensaver thing, but otherwise, this works for me.
Comment 5 Thomas Sailer 2008-06-02 16:57:23 EDT
Works for me; are you going to request this to be pushed to -testing or -stable?
Comment 6 Christopher Stone 2008-06-07 17:05:33 EDT
I just noticed that the /etc/kde/kdm/background.rc file points to a non-existant
file:
Wallpaper=/usr/share/backgrounds/waves/2-sulphuric-waves-day.1600.png
Comment 7 Kevin Kofler 2008-06-07 17:17:27 EDT
Oops... That's overridden by the theme we set, it's left over from the 
configuration we tried before we had fedorawaves-kdm-theme, when the Waves 
backgrounds weren't the final ones yet.
Comment 8 Fedora Update System 2008-06-20 15:13:30 EDT
kde-settings-4.0-24.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-settings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5536
Comment 9 Fedora Update System 2008-07-01 01:25:18 EDT
kde-settings-4.0-24.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Kevin Kofler 2008-07-01 19:35:27 EDT
gnome-keyring-pam (which is not set up for KDM by this update) doesn't appear 
to work properly with KDM. I installed this update, then manually installed 
gnome-keyring-pam which was not installed. As a result, NM no longer asked me 
for my keyring password, but it also was not able to fetch the WPA key from the 
keyring (and prompted me for it). And yes, my GNOME keyring password is the 
same as my login password. Removing gnome-keyring-pam again restored the status 
quo (have to enter the keyring password, but the WPA key can be fetched from 
the keyring just fine).
Comment 11 Rex Dieter 2008-07-01 20:16:03 EDT
Kevin, there are HOWTO's for that.  In short, if you weren't using
gnome-keyring-pam before, you need to reset your keyring (password?), and start
over, then everything "just works".  Yes, far from ideal, but oh well.
Comment 12 Rex Dieter 2008-07-01 20:39:14 EDT
For completeness, here's the guide I (basically) followed to get it to work for me:
http://fedoraunity.org/Members/thomasj/Gnome-keyring
Comment 13 Kevin Kofler 2008-07-01 20:44:19 EDT
The HOWTO says:
> If you are useing NetworkManager (nm-applet) for your Wlan and you log in
> next time at Gnome, you will be asked for a new Password for
> gnome-keyring-manager. Give the same as your login password. From there your
> keyring will automatic opened for you when you login.

But my keyring password is ALREADY the same as my login password. Weird...
Comment 14 Kevin Kofler 2008-07-02 20:24:48 EDT
Evidence that it's not just me: 
https://bugzilla.redhat.com/show_bug.cgi?id=453880

Note You need to log in before you can comment on or make changes to this bug.