Bug 447274 - kernel-xen does not boot
kernel-xen does not boot
Status: CLOSED DUPLICATE of bug 437930
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 04:47 EDT by Jan ONDREJ
Modified: 2008-05-19 09:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 05:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-05-19 04:47:45 EDT
Description of problem:
After showing this line:
  (XEN) Xen is relinqusihing VGA console.
xen kernel goes to infinit loop. Nothing more happens on my notebook. There was
no problems with Xen kernels before update to F9.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.25.3-1.fc9.i686

How reproducible:
Always.

Steps to Reproduce:
1. boot kernel-xen on my notebook :)
  
Actual results:
infinite loop

Expected results:
you know :)

Additional info:
Same problem on my colleagues computer.
I can provide more info if required.
Comment 1 Mark McLoughlin 2008-05-19 05:03:30 EDT
Unfortunately, kernel-xen in F-9 does not support Dom0, so this is expected.

If you require a Xen Dom0, you'll need to use F-8 until F-10.

See here for more details:

  http://fedoraproject.org/wiki/Features/XenPvops

*** This bug has been marked as a duplicate of 437930 ***
Comment 2 Jan ONDREJ 2008-05-19 05:17:09 EDT
F9 paravirtualized host can't be installed on F8 too. Is it a known problem?
This kernel works on none system.

kernel BUG at arch/x86/xen/time.c:122!
invalid opcode: 0000 [#1] SMP
Modules linked in:

Pid: 0, comm: swapper Not tainted (2.6.25-2.fc9.i686.xen #1)
EIP: e019:[<c0405bf3>] EFLAGS: 00010282 CPU: 0
EIP is at xen_setup_timer+0xa2/0xae
EAX: fffffff2 EBX: 00000005 ECX: 00000000 EDX: c0756f80
ESI: c063e540 EDI: 00000005 EBP: c0756f94 ESP: c0756f7c
 DS: e021 ES: e021 FS: 00d8 GS: 0000 SS: e021
Process swapper (pid: 0, ti=c0756000 task=c071f3a0 task.ti=c0756000)
Stack: c1a2fc18 c1a2fbac 912987cf 00000007 00000000 00000000 c0756fa8 c076373b
       00000020 c07a6968 c1a36968 c0756fd4 c075d8a1 3f861000 00001e5a c1a39000
       0000a000 00007968 c078680c 00864000 c07867e4 c0722b80 c0756ffc c07632ea
Call Trace:
 [<c076373b>] ? xen_time_init+0xd7/0xe4
 [<c075d8a1>] ? start_kernel+0x2b7/0x345
 [<c07632ea>] ? xen_start_kernel+0x32c/0x334
 =======================
Code: 00 00 00 89 51 20 8d 55 ec 89 41 1c b8 ac fb 79 c0 89 d9 03 04 9d 80 30 75
c0 89 fb 89 45 ec e8 14 47 3a 00 83 c4 0c 85 c0 74 04 <0f> 0b eb fe 8d 65 f4 5b
5e 5f 5d c3 55 b8 18 fc 79 c0 89 e5 57
EIP: [<c0405bf3>] xen_setup_timer+0xa2/0xae SS:ESP e021:c0756f7c
---[ end trace ca143223eefdc828 ]---
Kernel panic - not syncing: Attempted to kill the idle task!
Comment 3 Mark McLoughlin 2008-05-19 08:17:56 EDT
Jan: you need to update your F-8 Dom0 to kernel-xen-2.6-2.6.21.7-2.fc8

See bug #436859 and:

https://admin.fedoraproject.org/updates/F8/FEDORA-2008-2618
Comment 4 Jan ONDREJ 2008-05-19 09:07:39 EDT
Thank you. Just for anyone reading this the -3.fc8 kernel is required.
Works for me.

Note You need to log in before you can comment on or make changes to this bug.