Bug 447292 - 'BadAlloc (insufficient resources for operation)' when using Compiz
'BadAlloc (insufficient resources for operation)' when using Compiz
Status: CLOSED DUPLICATE of bug 448538
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F9Target
  Show dependency treegraph
Reported: 2008-05-19 07:23 EDT by David Nielsen
Modified: 2009-02-21 08:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-21 08:45:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg log (78.46 KB, application/octet-stream)
2008-05-19 07:23 EDT, David Nielsen
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 194638 None None None Never

  None (edit)
Description David Nielsen 2008-05-19 07:23:44 EDT
Description of problem:

[david@localhost ~]$ totem

(totem:26166): GLib-GObject-WARNING **: IA__g_object_new_valist: object class
`GThemedIcon' has no property named `names'

(totem:26166): GLib-GIO-CRITICAL **: g_themed_icon_constructed: assertion
`themed->names != NULL && themed->names[0] != NULL' failed

(totem:26166): GLib-CRITICAL **: g_strv_length: assertion `str_array != NULL' failed
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve
property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value
"((GString*) 0x23f1c80)" of type `GString'
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 51 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

using Metacity works around this issue and movies play fine. It appears to
happen when running compiz and a window has been or is fullscreened (not
required to be the application displaying the bug)

This is on a r200 card but I have reports from friends with other cards.

Likely related to:

Version-Release number of selected component (if applicable):
Comment 1 David Nielsen 2008-05-19 07:23:44 EDT
Created attachment 305927 [details]
Xorg log
Comment 2 Matěj Cepl 2008-05-30 17:39:00 EDT

*** This bug has been marked as a duplicate of 448538 ***
Comment 3 David Nielsen 2009-02-21 08:45:03 EST

*** This bug has been marked as a duplicate of bug 448538 ***

Note You need to log in before you can comment on or make changes to this bug.