Bug 447304 - Backout WAR for ia64 systems using "machvec=dig" on boot line
Backout WAR for ia64 systems using "machvec=dig" on boot line
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
medium Severity low
: rc
: ---
Assigned To: Cong Wang
:
Depends On: 446188
Blocks: RHEL5u2_relnotes RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-05-19 08:48 EDT by Prarit Bhargava
Modified: 2013-09-29 22:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
(ia64) Some systems may be unable to boot the kdump kernel properly. In such cases, use the machvec=dig kernel parameter.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-21 02:03:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5 fix for this issue (1.10 KB, patch)
2008-05-19 08:52 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2008-05-19 08:48:45 EDT
BZ 218667 comment #5 is a patch that contains a WAR for ia64 systems to use
"machvec=dig" on the boot line.  BZ 446188 is a fix for this issue and WAR in
218667 is no longer needed.

(Patch will be attached shortly.  This BZ explicitly depends on the fix for
446118 being committed prior to the WAR in 218667 being removed).
Comment 1 Prarit Bhargava 2008-05-19 08:52:13 EDT
Created attachment 305934 [details]
RHEL5 fix for this issue

Must be applied AFTER fix for 446188 is committed to kernel.
Comment 2 Neil Horman 2008-05-19 12:40:19 EDT
I'm not sure we want to do this.  Even if I wait until the proposed change on
rhkl is picked up, If I back this out, theres no guarantee that people won't try
to use a newer kdump package with an older kernel.  In those cases kdump will
load just fine, but on a kernel panic, the kdump kernel boot will fail.  A
Install dependency isn't going to help here either, since it won't stop people
from using an older kernel on reboot.  I'd really rather not tie in version
dependencies like that.  I think perhaps the best thing to do is to leave it
alone, and add a release note telling people that they can manually remove that
setting from /etc/sysconfig/kdump if they have an appropriately updated system.
 Thoughts?
Comment 3 Prarit Bhargava 2008-05-19 12:49:25 EDT
Good point, but if a user uses an old kernel + new kdump, or vice versa, they
are using an unsupported configuration of RHEL.

P.
Comment 9 Ryan Lerch 2008-08-10 22:15:49 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes. 

This Release Note is currently located in the Known Issues section.
Comment 10 Ryan Lerch 2008-08-10 22:15:49 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Note You need to log in before you can comment on or make changes to this bug.