Bug 447308 - Network manager doesn't init network on boot properly and trouble with service restart
Network manager doesn't init network on boot properly and trouble with servic...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 09:34 EDT by Andrey Gusev
Modified: 2009-06-11 03:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-14 16:23:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
message log of boot (70.24 KB, application/plain-text)
2008-05-19 09:34 EDT, Andrey Gusev
no flags Details

  None (edit)
Description Andrey Gusev 2008-05-19 09:34:19 EDT
Description of problem: After booting, ip address doesn't set for my network
card. I tried and dhcp and static ip address. After this, I do:
service network restart

If ip address is static all became good. If I use dhcp I see error, but eth0
reinit succefull:
[root@andrey_gusev tmp]# LANG=C service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:
Determining IP information for eth0...dhclient(4904) is already running - exiting.

This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report for this software via the Red Hat Bugzilla site:
    http://bugzilla.redhat.com

exiting.
 failed.
                                                           [FAILED]




Version-Release number of selected component (if applicable):
[andrey@andrey_gusev ~]$ rpm -qi NetworkManager
Name        : NetworkManager               Relocations: (not relocatable)
Version     : 0.7.0                             Vendor: Fedora Project
Release     : 0.9.3.svn3623.fc9             Build Date: Чтв 01 Май 2008 00:27:32

Steps to Reproduce:
1. boot 
2. try to restart network, because ip adress doesn't set
3.
  
Actual results:
ip address doesn't set. Error message on service restarting.

Expected results:
Ip address set and no error message on restarting.

Additional info:
In attachment message log of boot.
Comment 1 Andrey Gusev 2008-05-19 09:34:19 EDT
Created attachment 305941 [details]
message log of boot
Comment 2 Andrey Gusev 2008-05-21 04:12:25 EDT
Workaround is disable NetworkManager
Comment 3 Dan Williams 2008-05-21 10:52:13 EDT
I assume you're using static IP configuration?  Could you attach your
/etc/sysconfig/network-scripts/ifcfg-eth0 file?

Also, could you update to the latest NM in f9-updates-testing (svn3675 I
believe) as this fixes a few issues with reading the configuration you've set up
in ifcfg-eth0.
Comment 4 Andrey Gusev 2008-05-22 05:44:18 EDT
I tried both variants. My current configuration:
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=00:18:F3:77:8D:DC

I updated from fedora 7 and it was static ip. 
I'm trying package from testing.
Comment 5 Andrey Gusev 2008-05-22 06:10:03 EDT
I got  NetworkManager-glib-0.7.0-0.9.3.svn3675.fc9.i386.rpm  and
NetworkManager-0.7.0-0.9.3.svn3675.fc9.i386.rpm, upgraded and rebooted. Booting
is ok, eth0 was upped. But, I did "service network restart", I have seen message
about error below. 
I try static ip also.
Comment 6 Andrey Gusev 2008-05-22 06:31:03 EDT
I checked static ip, it works good on starting. On restarting, there is messages:
Shutting down interface eth0:  [OK]

Shutting down loopback interface:  [OK]

Bringing up loopback interface:  [OK]

Bringing up interface eth0:  RTNETLINK answers: File exists
Error adding address 192.168.1.103 for eth0.
[OK]
Comment 7 Dan Williams 2008-05-22 11:57:25 EDT
If you're allowing NetworkManager to control the interface, then you don't need
to use the 'network' service for that interface.  You can add:

NM_CONTROLLED=yes

or

NM_CONTROLLED=no

to the ifcfg file to indicate which service (either NetowrkManager or network)
should control the device.

Comment 8 Dan Williams 2009-02-14 16:23:15 EST
Please reopen if the suggestions in comment #7 don't work for you.
Comment 9 f14f21 2009-06-11 03:42:22 EDT
if u want to config ur eth manually no need to use network manager :

   1) /sbin/chkconfig --level 0123456 NetworkManager off
   2) use NM_CONTROLLED=no in 
      /etc/sysconfig/network-scripts/ifcfg-eth0 (as Williams  said)
   3)i assumed ur network service start level is set in ur boot run-level .
   4)reboot linux

Note You need to log in before you can comment on or make changes to this bug.