Bug 447319 - virt-manager can't virtualize anything
virt-manager can't virtualize anything
Status: CLOSED DUPLICATE of bug 441619
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 10:27 EDT by Kamil Pawlowski
Modified: 2008-05-19 10:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 10:53:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Pawlowski 2008-05-19 10:27:08 EDT
Description of problem:

When I create virtual machine I get this error msg:
Unable to complete install '<class 'libvirt.libvirtError'>
virDomainCreateLinux() failed internal error QEMU quit during console startup
qemu: could not open disk image /home/kamil/debian2.img

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 651, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 845, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 866, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 833, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed internal error QEMU quit during
console startup
qemu: could not open disk image /home/kamil/debian2.img

'


Version-Release number of selected component (if applicable):
libvirt-0.4.2-1.fc9.x86_64
virt-manager-0.5.4-3.fc9.x86_64

This same result I have in any virtual system (qemu, kqemu, kvm)
Comment 1 Daniel Berrange 2008-05-19 10:34:25 EDT
If you have SELinux enabled, it is probably dieing because the disk image is not
in the required location. Try again using /var/lib/libvirt/images  as the
location.  A forthcoming update will make this the default directory in
virt-manager file dialog
Comment 2 Kamil Pawlowski 2008-05-19 10:48:46 EDT
Yeah, this helps. Anyway I don't get any warning in SELinux tool and any warning
when I create virtual system using virt-manager, one of them should help people
like me
Comment 3 Daniel Berrange 2008-05-19 10:53:52 EDT

*** This bug has been marked as a duplicate of 441619 ***

Note You need to log in before you can comment on or make changes to this bug.