Bug 447323 - Snake renders F9 system unbootable (GRUB GRUB GRUB..)
Snake renders F9 system unbootable (GRUB GRUB GRUB..)
Status: CLOSED DUPLICATE of bug 446362
Product: Fedora
Classification: Fedora
Component: snake (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: James Laska
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 10:57 EDT by Will Woods
Modified: 2013-09-02 02:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 10:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-05-19 10:57:41 EDT
With a freshly-installed F9 system, if you use SNAKE to tell it to install
something else (e.g. Fedora 8), at reboot you'll either get:

GRUB [hang]

or GRUB GRUB GRUB GRUB [infinite loop]

Perhaps it's invoking grub incorrectly somehow?
Comment 1 Will Woods 2008-05-19 11:14:07 EDT
Interestingly I've seen similar complaints from people using Hibernate for the
first time after boot. Maybe there's a deeper problem with GRUB?
Comment 2 James Laska 2008-05-19 11:15:46 EDT
Greetings Will.  Can you note the version of snake used, the architecture you're
seeing this on, and any cmdline arguments used?

Any chance you have the {grub,yaboot,elilo}.conf before rebooting?

Thanks!
James
Comment 3 Will Woods 2008-05-19 11:26:12 EDT
I'm using the F9 default snake - snake-0:0.11-0.5.fc9.

grub.conf exists (and looks normal) before reboot.

Workaround is to boot media into rescue mode and run:
  chroot /mnt/sysimage grub-install /dev/sda
Which doesn't change grub.conf. So it's kind of perplexing.
Comment 4 James Laska 2008-05-19 15:39:49 EDT
Not able to reproduce on F-9 i386, x86_64 or ppc so far.  

Anything funky about the environment (e.g. kvm, qemu, bare metal, vmware)?  Is
there a non-default partitioning setup involved (e.g. grub on a partition
instead of MBR)?

Would you mind attaching the grub.conf and maybe /var/log/anaconda.log from the
previous install?  Thanks!
Comment 5 Will Woods 2008-05-19 15:51:11 EDT
Bare metal machine. The only thing of note about the partitioning is that
there's no /boot partition - we've got / and swap and that's it. Happens on i386
and x86_64.
Comment 6 James Laska 2008-05-19 16:52:51 EDT
Rats, no luck reproducing using the environment specified in comment#5.  Any
chance I can get access to the system you're seeing this on?  
Comment 7 Will Woods 2008-06-21 10:59:07 EDT
Not snake-specific, AFAICT.

*** This bug has been marked as a duplicate of 446362 ***

Note You need to log in before you can comment on or make changes to this bug.