Bug 447348 - gui displays garbage on intel gm965 based video
gui displays garbage on intel gm965 based video
Status: CLOSED DUPLICATE of bug 205361
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.7
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks: RHEL4u7_relnotes
  Show dependency treegraph
 
Reported: 2008-05-19 12:24 EDT by Robert M Williams
Modified: 2009-03-11 18:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 17:35:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output of system (1.99 KB, text/plain)
2008-05-19 12:24 EDT, Robert M Williams
no flags Details
initial post-install xorg.conf file (2.64 KB, text/plain)
2008-05-19 12:25 EDT, Robert M Williams
no flags Details
xorg log (59.63 KB, text/plain)
2008-05-19 12:25 EDT, Robert M Williams
no flags Details
i386 version of lspci output for same target system (1.99 KB, text/plain)
2008-05-20 11:48 EDT, Robert M Williams
no flags Details
i386 version of xorg.conf for same target system (2.65 KB, text/plain)
2008-05-20 11:48 EDT, Robert M Williams
no flags Details
i386 version of X log for same target system (57.66 KB, text/plain)
2008-05-20 11:49 EDT, Robert M Williams
no flags Details
vesa_drv.o for i386 (20.28 KB, application/octet-stream)
2008-05-23 10:30 EDT, Robert M Williams
no flags Details
vesa_drv.o for x86_64 (28.91 KB, application/octet-stream)
2008-05-23 10:31 EDT, Robert M Williams
no flags Details

  None (edit)
Description Robert M Williams 2008-05-19 12:24:08 EDT
Description of problem:
all gui based functions (install, gdm, system-config-display, etc.) are
unusable as display is basically patches of color blocks

Version-Release number of selected component (if applicable):
rhel 4.7 re20080515.0

How reproducible:
always

Steps to Reproduce:
1.boot install media
2.proceed to gui based install
3.once switched from text to gui is attempted screen becomes unusable
4.or
5.boot install media
6.perform text based install
7.on reboot after install completes screen is unusable
  
Actual results:
garbage displayed in GUI mode

Expected results:
readable display

Additional info:
attempted to manually adjust parts of xorg.conf file to work around issue
- adjusted monitor settings to match hardware specs - failed
- tried framebuffer driver instead of vesa - failed
- tried i810 driver - failed
reset xorg.conf to original settings and ran system-config-display
system-config-display unusable once switched to graphical mode due to garbage
displayed
Comment 1 Robert M Williams 2008-05-19 12:24:08 EDT
Created attachment 305973 [details]
lspci output of system
Comment 2 Robert M Williams 2008-05-19 12:25:18 EDT
Created attachment 305974 [details]
initial post-install xorg.conf file
Comment 3 Robert M Williams 2008-05-19 12:25:54 EDT
Created attachment 305975 [details]
xorg log
Comment 6 Jonathan Blandford 2008-05-20 10:44:13 EDT
According to ajax, rhel4 i810 support stops with 945.  965 is vesa-only in
rhel4.  However, given that vesa doesn't seem to work, this might be an x86_64
issue.  Does an x86 install work with 965?
Comment 7 Robert M Williams 2008-05-20 10:58:32 EDT
with x86 version there is no corrupted display, however the x server is unable
to start. so it would appear that the vesa driver is not working with this chipset.
Comment 8 Cameron Meadors 2008-05-20 11:33:56 EDT
I reproduced this on a Lenovo Thinkcentre 8807 (graphics card is Q965) with
RHEL4-U7-re20080515.0 x86_64.  Anaconda tried to use the VESA driver and I got
garbage on the screen when the GUI install started.

I also tried i386 on the same machine.  Anaconda again tried to use VESA, but X
failed to start.  Finally it fell back to the Text interface to continue the
install.
Comment 9 Robert M Williams 2008-05-20 11:48:22 EDT
Created attachment 306142 [details]
i386 version of lspci output for same target system
Comment 10 Robert M Williams 2008-05-20 11:48:58 EDT
Created attachment 306143 [details]
i386 version of xorg.conf for same target system
Comment 11 Robert M Williams 2008-05-20 11:49:37 EDT
Created attachment 306144 [details]
i386 version of X log for same target system
Comment 13 Cameron Meadors 2008-05-22 11:59:01 EDT
I just retested with RHEL 4.6 i386 on the same hardware I testing 4.7 on.  The
graphical install worked with the VESA driver.
Comment 14 Cameron Meadors 2008-05-22 14:20:34 EDT
x86_64 worked as well.

Just to note, I am not testing on a laptop.  So this is not just the mobile version.
Comment 15 Kevin E. Martin 2008-05-22 16:19:46 EDT
Note that both the kernel and xorg-x11 packages can affect the vesa driver.

Cameron and/or Robert, what happens when you try the 4.6 kernel with the 4.7
xorg-x11 package?  And, conversely, what happens when you try the 4.7 kernel
with the 4.6 xorg-x11 pkg?  This would help narrow down if it's an xorg-x11 or
kernel issue.
Comment 17 Robert M Williams 2008-05-23 10:30:30 EDT
Created attachment 306504 [details]
vesa_drv.o for i386

vesa driver from rhel 4.6
Comment 18 Robert M Williams 2008-05-23 10:31:27 EDT
Created attachment 306506 [details]
vesa_drv.o for x86_64

vesa driver from rhel 4.6 for x86_64 based systems
Comment 19 Robert M Williams 2008-05-23 10:32:52 EDT
I was able to get x sessions working using the vesa_drv.o from rhel 4.6
The vesa_drv.o alone was enough to provide x sessions on a system install in
text mode.
Comment 20 Cameron Meadors 2008-05-23 11:23:21 EDT
I installed a clean 4.6 with all updates on x86_64.  X starts fine.  I updated
to the 4.7 xorg-x11 package and X still works.

I will know update to the 4.7 kernel and verify that that still breaks.  Then
downgrade the xorg-x11 package to the 4.6 version.
Comment 21 Cameron Meadors 2008-05-23 13:56:34 EDT
Correction.  4.6 with 4.7 xorg-x11 package fails as originally reported.

4.6 xorg-x11 with 4.7 kernel works fine.  Looks like the culprit is X.

This was all tested on RHEL 4.6 AS x86_64.  4.7 packages were from 20080515.0.
Comment 22 Don Domingo 2008-05-25 18:18:45 EDT
this bug has been tagged for inclusion in the RHEL4.7 release notes. please post
the necessary content for it. thanks!
Comment 23 Alexander Todorov 2008-05-26 05:23:05 EDT
Don, here's a sample text:

<quote>
Installing this release or upgrading from Red Hat Enterprise Linux 4 update 6 to
this release may cause X to not work on intel gm965 based video chipset.
</quote>

Robert, Cameron,
please advise if the above text is correct.

Thanks!
Comment 24 Don Domingo 2008-05-26 18:02:20 EDT
thanks Alex. is there no workaround for this?
Comment 25 Ben Levenson 2008-05-27 14:27:06 EDT
(In reply to comment #24)
> thanks Alex. is there no workaround for this?

I don't believe so.   All of the video drivers appear to be failing with this
chipset.
Comment 26 Don Domingo 2008-05-27 18:26:14 EDT
thanks Ben. revising release notes as:

<quote>
(x86_64) The X server of this release may fail on systems that use chipsets
based on Intel GM965.
</quote>

please advise if any further revisions are required. thanks!
Comment 28 Zack Cerza 2008-05-29 11:46:17 EDT
This is caused by the current patch for bug #205361
Comment 29 Don Domingo 2008-06-02 19:15:27 EDT
Hi,

the RHEL4.7 release notes deadline is on June 17, 2008 (Tuesday). they will
undergo a final proofread before being dropped to translation, at which point no
further additions or revisions will be entertained.

a mockup of the RHEL4.7 release notes can be viewed here:
http://intranet.corp.redhat.com/ic/intranet/RHEL4u7relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 30 Adam Jackson 2008-06-04 15:13:48 EDT
This doesn't need release noting.  The patch is just broken and needs to be fixed.

I've backed it out as of xorg-x11-6.8.2-1.EL.47.
Comment 31 Don Domingo 2008-06-04 18:50:17 EDT
Adam,
does this mean that the X server no longer fails on Intel gm965?
Comment 34 Adam Jackson 2008-06-13 17:35:47 EDT
Fixed vesa blanking patch applied to -1.EL.50.  

Closing this as a dupe of the original VBE blanking bug.

*** This bug has been marked as a duplicate of 205361 ***

Note You need to log in before you can comment on or make changes to this bug.