Bug 447375 - [Netapp 5.3 bug] mkinitrd doesn't provide complete support for SANBoot.(root on multipath iSCSI).
[Netapp 5.3 bug] mkinitrd doesn't provide complete support for SANBoot.(root ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Peter Jones
netapp
: OtherQA
Depends On:
Blocks: 373081 446125
  Show dependency treegraph
 
Reported: 2008-05-19 14:24 EDT by nandkumar mane
Modified: 2014-09-08 10:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:11:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root on multipath(iSCSI) mkinitrd patch (2.58 KB, patch)
2008-05-19 14:48 EDT, nandkumar mane
no flags Details | Diff

  None (edit)
Description nandkumar mane 2008-05-19 14:24:30 EDT
Description of problem:
mkinitrd, shipped with RHEL5.2 doesn't support multipathed devices completely.
For multipathed device, the initrd image creates iscsi login to target through 
only one path. 


Version-Release number of selected component (if applicable):


How reproducible:
Very reproducible

Steps to Reproduce:
1.Run install on iscsi multipathed device (Root on multipath).
2.At the end of installation process anaconda will run mkinitrd to create new 
initrd image.
3. Once installation is done, do reboot.
4. During 1st boot you will see that initiator has logged in through only one 
path.
  
Actual results:
During initrd, initiator will be logged in through only one path.

Expected results:
During initrd, iscsi initiator should be logged in to the target through all 
configured paths.

Additional info:
Comment 1 nandkumar mane 2008-05-19 14:48:08 EDT
Created attachment 305992 [details]
root on multipath(iSCSI) mkinitrd patch

After applying attached patch mkinitrd creates proper initrd, which makes sure
that iscsi initiator will login to target through all configured paths.
Comment 3 RHEL Product and Program Management 2008-06-02 15:58:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Denise Dumas 2008-06-24 15:59:58 EDT
Because we're merging the Fedora 9 encryption support into RHEL5.3, the attached
patch may require changes. We'll re-evaluate this one in ~2 weeks, once the
encryption support is in. 
Comment 10 NetApp filed bugzillas 2008-08-26 09:51:50 EDT
Have we included patch (id=305992) comment #1 in 5.3? I don't see any update here.
Comment 11 Peter Jones 2008-09-15 13:51:34 EDT
This support should be present in mkinitrd-5.1.19.6-31 .
Comment 13 nandkumar mane 2008-11-06 00:31:05 EST
mkinitrd is creating proper initrd image. Now we can see initiator is logged in to all the configured paths during boot time. 

Thank you for including patch (Comment #1).
Comment 15 errata-xmlrpc 2009-01-20 17:11:52 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0237.html

Note You need to log in before you can comment on or make changes to this bug.