Bug 447386 - firefox crashes repeatedly in js_Invoke
firefox crashes repeatedly in js_Invoke
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 15:00 EDT by Bryan O'Sullivan
Modified: 2008-07-18 09:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 09:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace, courtesy of gdb (10.80 KB, text/plain)
2008-05-19 15:02 EDT, Bryan O'Sullivan
no flags Details

  None (edit)
Description Bryan O'Sullivan 2008-05-19 15:00:32 EDT
Description of problem:

The version of firefox bundled with Fedora 9 is extremely unstable, and crashes
every few minutes for me as follows:

Program received signal SIGSEGV, Segmentation fault.
js_Invoke (cx=0x7f67a518a480, argc=0, vp=0x7f67a3820310, flags=2)
    at jsinterp.c:1096

It can take a little while to provoke this crash, but to date my longest
browsing session has lasted perhaps 15 minutes.

I know that in some sense this isn't your fault because you didn't develop the
Firefox beta, but really, whoever decided to bundle such a crappy codebase with
a major distro upgrade needs some help making wiser decisions.  Packaging a
useless version of the single most important desktop app was the sort of
decision one might easily anticipate leading to, shall we say, less than
complete user satisfaction.

Version-Release number of selected component (if applicable):

firefox-3.0-0.60.beta5.fc9.x86_64
xulrunner-1.9-0.60.beta5.fc9.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Browse to a web site that uses Javascript. I'm trying to buy computer parts
at http://www.centralcomputer.com/ for example.
2. Click around to different web pages for a few minutes.
3. Crash!
  
Actual results:

An unusable web browser.

Expected results:

A stable web browser.

Additional info:

I have a few Firefox addons installed:

Delicious Bookmarks
Firebug
Greasemonkey
YSlow
Comment 1 Bryan O'Sullivan 2008-05-19 15:02:15 EDT
Created attachment 305997 [details]
Backtrace, courtesy of gdb

I've attached the backtrace that seems to occur most frequently.
Comment 2 Bryan O'Sullivan 2008-05-19 15:39:15 EDT
There are several other crashes in Javascript-related code. I can keep piling
them up here, if they might seem useful.
Comment 3 Balaji G 2008-06-22 05:33:28 EDT
Changing status to ASSIGNED

Cheers,
Balaji
Comment 4 Matěj Cepl 2008-06-23 12:17:22 EDT
Are you able to reproduce this bug while running firefox with -safe-mode parameter?
Comment 5 Bryan O'Sullivan 2008-06-23 14:06:08 EDT
I haven't been able to reproduce the problem since I upgraded to FF3 final.
Comment 6 Martin Stransky 2008-07-18 09:52:45 EDT
Thanks for the info, closing.

Note You need to log in before you can comment on or make changes to this bug.