Bug 447425 - Exit from startx hangs
Exit from startx hangs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 17:16 EDT by Pete Zaitcev
Modified: 2008-08-13 17:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 17:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors (6.35 KB, text/plain)
2008-05-19 17:17 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2008-05-19 17:16:10 EDT
Description of problem:

When I select "Logout" from a panel menu, the session ends, but the
X server does not exit. Ctrl-Alt-Backspace works to kill it, but it's
uncoth. This is regression in Rawhide against F9.

Version-Release number of selected component (if applicable):

gnome-panel-2.23.2.1-1.fc10.x86_64
gdm-2.22.0-6.fc10.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Boot in level 3 (just append 3 in GRUB menu on the fly)
2. startx
3. Exit X session
  
Actual results:

Hang at empty screen (not a fatal system hang, but nonetheless)

Expected results:

Exit to command prompt.

Additional info:

It may be not so recent, because I let my Rawhide system to follow
F9 for testing purposes and switched back to Rawhide a couple of
days ago. According to yum.log, previous panel was
gnome-panel-2.23.2.1-1.fc10.x86_64 (the panel is the correct
component here, right?)
Comment 1 Pete Zaitcev 2008-05-19 17:17:00 EDT
Created attachment 306015 [details]
.xsession-errors
Comment 2 darrell pfeifer 2008-05-20 00:55:38 EDT
The same problem happens to me with sessions using gdm. The problem is new with
fc10.

Not sure if this is related but gnome-session and gnome settings in general seem
to be having problems in fc10

https://bugzilla.redhat.com/show_bug.cgi?id=446987
Comment 3 Pete Zaitcev 2008-08-13 17:11:12 EDT
This does not happen on "current" Rawhide (running Xorg server 1.4.99.906,
gdm-2.23.2-1.fc10, gnome-panel-2.23.6-1.fc10). As the original requestor,
I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.