Bug 447428 - aspell sigserv on checking file with 0 length
aspell sigserv on checking file with 0 length
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: aspell (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 17:29 EDT by Anatoly Pugachev
Modified: 2008-06-06 18:10 EDT (History)
0 users

See Also:
Fixed In Version: 0.60.5-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 18:10:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anatoly Pugachev 2008-05-19 17:29:45 EDT
Description of problem:

aspell is getting sigserv signal when trying to check file which is 0 bytes size.

Version-Release number of selected component (if applicable):

aspell-0.60.5-3.fc7

How reproducible:


Steps to Reproduce:
1. touch aspell-test-0-size.txt
2. aspell -c aspell-test-0-size.txt
  
Actual results:

coredump

Expected results:

not to coredump

Additional info:

$ gdb `which aspell` core.22318
GNU gdb Red Hat Linux (6.6-45.fc8rh)
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

warning: Can't read pathname for load map: Input/output error.
Reading symbols from /usr/lib/libaspell.so.15...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libaspell.so.15
Reading symbols from /usr/lib/libncursesw.so.5...(no debugging symbols
found)...done.
Loaded symbols for /usr/lib/libncursesw.so.5
Reading symbols from /lib/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /usr/lib/libstdc++.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libgcc_s.so.1...
(no debugging symbols found)...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/libtinfo.so.5...(no debugging symbols found)...done.
Loaded symbols for /lib/libtinfo.so.5
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
(no debugging symbols found)
Core was generated by `aspell -c aspell-test-0-size.txt'.
Program terminated with signal 11, Segmentation fault.
#0  0x02ba8e8f in acommon::DecodeUtf8::decode () from /usr/lib/libaspell.so.15
(gdb) bt
#0  0x02ba8e8f in acommon::DecodeUtf8::decode () from /usr/lib/libaspell.so.15
#1  0x02baf5c0 in acommon::DocumentChecker::process () from /usr/lib/libaspell.so.15
#2  0x0806b5f2 in ?? ()
#3  0x08055e37 in acommon::available_filters ()
#4  0x080612da in acommon::available_filters ()
#5  0x009f1390 in __libc_start_main () from /lib/libc.so.6
#6  0x0804d201 in acommon::available_filters ()
Missing separate debuginfos, use: debuginfo-install aspell.i386
Comment 2 Matteo Castellini 2008-05-24 06:35:23 EDT
Thank you for taking the time to report this bug report. Unfortunately, 
that stack trace is not very useful in determining the cause of the crash,
because there is not a symbolic stack trace.  In order to get a symbolic
stack trace, the appropriate debuginfo packages need to be installed.
In order to accomplish this, you can issue:

# yum -y install yum-utils
# debuginfo-install aspell
 
Please see http://fedoraproject.org/wiki/StackTraces for more information about
stack traces.
Comment 3 Fedora Update System 2008-05-29 05:38:05 EDT
aspell-0.60.5-6.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-05-29 07:47:27 EDT
aspell-0.60.5-4.fc8 has been submitted as an update for Fedora 8
Comment 5 Ivana Varekova 2008-05-29 07:47:59 EDT
Fixed in aspell-0.60.6-2.fc10, aspell-0.60.5-6.fc9, aspell-0.60.5-4.fc8.
Comment 6 Fedora Update System 2008-05-30 22:12:35 EDT
aspell-0.60.5-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update aspell'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4708
Comment 7 Anatoly Pugachev 2008-06-06 05:54:21 EDT
fixed with an update. aspell-0.60.5-6.fc9 doesn't sigfault anymore, thanks.
Comment 8 Fedora Update System 2008-06-06 18:10:16 EDT
aspell-0.60.5-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-06-06 18:10:54 EDT
aspell-0.60.5-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.